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JCSS Technical Reference Manual Identification

Identification

Document Identification

Software Identification

Document Title: JCSS Technical Reference Manual
Version: 7.0 Final

Product Name: JCSS
Product Release: 7.0

Documentation Conventions

This documentation uses specific formatting and typographic conventions to present the
following types of information:

* Objects, examples, and system I/O
* Object hierarchies
e Computer commands

e Lists and procedures

Objects, Examples, and System 1/O

Object Hierarchies

* Directory paths and file names are in standard Courier typeface:
C:\Netwars\User Data\Projects

¢ Function names in body text are in italics:

op_dist_outcome()

* The names of functions of interest in example code are in bolded Courier typeface:

/* determine the object ID of packet’s creation module */
src_mod objid = op pk creation mod get (pkptr);

* Variables are enclosed in angle brackets (< >):

<NETWARS path>\Scenario Builder\op admin\err log

Menu hierarchies are indicated by right angle brackets (>); for example:

Edit > Preferences > Advanced

JCSS/Release 7.0
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JCSS Technical Reference Manual

Computer Commands

Lists and Procedures

These conventions apply to Windows systems and navigation methods that use the
standard graphical-user-interface (GUI) terminology such as click, drag, and dialog box.

* Key combinations appear in the form “press <button>+x"; this means press the
<button> and x keys at the same time to do the operation.

* The mouse operations left-click (or click) and right-click indicate that you should press
the left mouse button or right mouse button, respectively.

Information is often itemized in bulleted (unordered) or numbered (ordered) lists:
¢ In bulleted lists, the sequence of items is not important.
¢ In numbered lists, the sequence of items is important.

Procedures are contained within procedure headings and footings that indicate the start
and end of the procedure. Each step of a procedure is numbered to indicate the
sequence in which you should do the steps.

TR-FM-iv
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Document Revision History

Document Revision History

Product
Release Date Version Chapter

Description of Change

November 30, 2007 7.0 Final All

- Began introduction of product name change to JCSS from
NETWARS.

- Updated figure 3-33 Logical View Selection dialog box, and
removed refs to Frame Relay, VTC, etc., in this section.

- Added list of filters to Show Network Browser section, and
added note that Modeler will not launch from JCSS without a
Modeler license.

- Updated LOS Settings section to include info about altitude and
altitude unit conversion.

- Modified Deploy Circuits section to clarify that sample procedure
is for generic circuit deployment and works for all circuits.

- Added figures to Deploy Broadcast Network and Deploy
Relationship sections.

- Updated Results Browser figure to reflect addition of Capacity
Planning tables/graphs for Link-16 (and UHF DAMA).

October 26, 2007 2007 3
Final

Appendix C

- Added sentence to “Show Logical Views” that Network Layer
Filters shown are only those which apply to the deployed network.

- Removed “Animate” section, and updated “Show Time
Controller” section.

- Added section on opening a Node Model using Modeler, and
setting related preferences (pgs 3-32 and 3-33.)

- Added “Save As Link Type” section (pg 3-100.)

Added and/or updated figures:

- 3-78 Free-Text Questions Report

- 3-120 through 3-122 UHF DAMA SATCOM Wizard
- 3-127 through 3-130 Multiplexer Circuit Deployment
- 3-131 View Multiplexer Circuits dialog box

- 3-132 Enable Cut-Through on Selected Devices

- 3-133 Disable Cut-Through on Selected Devices

- Removed “Scenario Treeview” references.

- Added Topology > Deploy Broadcast Network, and Topology >
Deploy Relationship.

- Added “Undo/Redo Template Units” to “Editing the Contents of
the Library” section.

October 10, 2007 2007 2
Draft

- Updated figures to reflect change to NETWARS v2007.

Updated figures:

- 3-8 updated models list

- 3-21 updated dialog box options layout
- 3-32 updated groups list
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Document Revision History

JCSS Technical Reference Manual

Release Date

Product
Version

Chapter

Description of Change

Appendix B
Appendix C

- 3-34 added UHF DAMA and Link 16 options and updated dialog
box layout

- 3-44 and 3-47 updated file path

- 3-56 updated dialog box layout

- 3-61 added Preview button

- 3-63 and 3-64 changed ‘phases’ to ‘scenarios’

- 3-88 and 3-89 updated list of tables

- 3-90 added Load button

- 3-93 updated dialog box layout

- 3-94 updated list order

- 3-99 updated list of pre-configured OPFACs and organizations
- 3-179 added figure of Probe Model Window

- 3-181 updated list of attributes

Changes to View menu:

- Added View > Background > Add CADRG/CIB Raster Catalog
Directories

- Added View > Background > Add MrSID Image

- Added View > Circuits

- Added View > Wireless Domains

- Added View > Visualize Protocol Configuration > IP Address
Types

Change to Scenarios menu:
- Removed Scenarios > Scenario Components submenu

Changes to Topology menu:

- Changed Topology > Import submenu to Topology > Import
Topology

- Added Topology > Import Topology > Convert DCI to
NETWARS Scenario

- Added Topology > Import Topology > From Configlets.

- Changed Topology > Model Assistant > View Error Log to
Topology > Model Assistant > Open Error Log.

- Added Topology > Link Operations > Import Links from File.
- Added Topology > Deploy Circuit.

- Removed Topology > Configuration Utilities > Promina.

- Changed Topology > Terrain > Define Trajectory to Topology >
Define Trajectory.

Change to Protocols menu:
- Added Protocols > IPv6 submenu.

Change to NetDoctor menu:
- Added NetDoctor > Configure/Run Trending
- Added NetDoctor > Open NetDoctor Log.

Change to DES menu:
- Changed DES > Panel Options submenu to DES > Panel
Operations.

- Updated Figure 4-1 to reflect new toolbar icons in Icon
Database.

- Added File > Manage Model Files submenu, and Edit >
Preferences.

- Updated figures to reflect change to NETWARS v2007.

- Updated Figure C-1to reflect current list of pre-configured
OPFACs and organizations in Library Treeview.
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JCSS Technical Reference Manual Document Revision History

Product
Release Date Version Chapter Description of Change

December 13, 2006 6.2 Final 2 - Removed refs to User’s Guides 1-4, since they are no longer
built into the NETWARS software.

3 - Clarified use of Rules folders (pg TR-3-22).
- Removed unnecessary step (old step 2) from View > Set Area
of Interest section.
- Removed reference to Map menu (changed to View >
Background > Map Edit Mode).
- Added Topology > Define Trajectory.
- Updated Figure 3-151, Traffic Flows Import dialog box (now
Figure 3-155), and accompanying text description.
- Removed ref to traffic_import_suppress_unrecognized_
sources_dialog preference from Unrecognized Traffic Assistant
section.
- Removed Traffic > Specify Core/Edge Devices.
- Updated list of Capacity Planning web reports (pg TR-3-145).

4 - Updated instructions for accessing Icon Database and locating
files.

December 8, 2006 6.2 Final 1 - Removed descriptions of editors that are not provided with
standard NETWARS.

2 - Updated “Open Project” section to direct users to use the Project
directory.
- Updated Figure 2-13 to reflect version 12.0.
- Updated Figure 2-19 and associated text to reflect new
Preferences Editor.

3 - Removed duplicate step from “Edit > Preferences > Device
Model Map > New” section, and added ref to specific directory.
- Updated figures 3-38, 3-79, 3-87, 3-88, 3-92, 3-170, 3-171,
3-179, 3-180, and 3-181.
- Added “DES > IER Results” section.

Appendix C - Updated refs from 11.5 to 12.0.
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Document Revision History JCSS Technical Reference Manual

Product
Release Date Version Chapter Description of Change
November 3, 2006 6.2 Final 3 - Provided updated figures: 3-1 (Scenario Builder with a project

open); 3-3, 3-5, 3-7, and 3-33 (removed references to old
UserGuide_SB_Scenario); 3-6 (removed Add Logical View
button); 3-34 (removed Type of View drop-down list, and
Re-use/Re-create options); 3-35 (added new Settings
drop-down); 3-79 (names in CCSD Summary Report); 3-87 and
3-88 (clearer); 3-101 (Library treeview changes); 3-113 (added
Classification drop-down); 3-111, 3-117, 3-187, and 3-188 (reflect
new toolbar buttons).

- Added new figures 3-36 and 3-37 for network showcase feature.

- Removed Map Menu (moved Map > Set Area of Interest to View
> Set Area of Interest, moved Map > Background > <options> to
View > Background > <options>, removed Map > Background >
Add CADRG/CIB Raster catalog directories, moved and renamed
Map > Background > Toggle Map Edit Mode to View >
Background > Map Edit Mode, moved Map > LOS Settings to
View > Show LOS > LOS Settings, moved Map > Clear LOS
Ranges to View > Show LOS > Clear LOS Ranges, moved Map
> Display LOS Legend to View > Show LOS > Display LOS
Legend, moved Map > View OPFAC Distances to View > OPFAC
Distances > View OPFAC Distances, moved Map > Remove
OPFAC Distances to View > OPFAC Distances > Remove
OPFAC Distances, removed Map > Define Trajectory, moved
Map > Animate to Scenarios > Animate.)

- Added Topology > Configuration Utilities > UHF DAMA
SATCOM and Topology > Configuration Utilities > Cut-through >
<options>.

- Moved Terrain menu options to Topology menu.
- Added Ctrl+W shortcut keys to Traffic Wizard section.

Appendices - Updated NETWARS System Adminstrator's Manual and moved
B, C,and D to new Appendices in this manual.
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Document Revision History

Description of Change

Product
Release Date Version Chapter
October 13, 2006 6.2 Draft 1
2
3
4 &5
Glossary

- Removed references to the IER Editor.

- Updated System Editor and Sign-in figures to reflect version 6.2.
- Removed File > Open Editor and Open Editor dialog box.

- Added File > New Project, File > Open Project, File > Open
Subordinate Query, File > New Other, File > Open Other, File >
Manage Model Files, and File > Recent Projects.

- Added IER Database menu and options.

- Added Help > Show All Logs.

- Added File > Close, File > Page Setup, File > Print Graphs, and
File > Manage Model Files.

- Removed File > Close Project and File > Close Subordinate
Query.

- Added Edit > Save Object Selection Set, Edit > Load Object
Selection Set, Edit > Edit Objects Using Template, and Edit > Edit
Attribute Template.

- Replaced Advanced Preferences dialog box with new
Preferences Editor dialog box.

- Added View > Show Logical Views, View > Show Network
Topology, View > Show Network Showcase, View > Open
Network Showcase Window, View > Demands, View > Paths,
View > Annotations, View > Layout > Lay Out Nodes Interactively,
View > Zoom > To Window, and View > Zoom > To All.

- Updated Edit Visualization Preferences dialog box.

- Changed View > Layout > Scale Selected Icons

to View > Layout > Scale Node Icons Interactively.

- Removed View > Network Views > Logical.

- Updated Scenario menu to reflect name change to Scenarios
menu. Added Scenarios > Scenario Components, Scenarios >
Reports > CCSD Summary, and Scenarios > Reports > SLD
Summary.

- Added Protocols > Servers, Protocols > Mainframes, Protocols
> TCP, Protocols > MPLS, Protocols > Ethernet, Protocols >
FDDI, Protocols > MANET, Protocols > UMTS, and Protocols >
Wireless LAN.

- Removed Topology > Import > Template OPFAC into Library
from XML.

- Added DES > Choose Statistics (Advanced), DES > Expert
Service Prediction, DES > Configure/Run Discrete Event
Simulation (Advanced), DES > Restart Discrete Event
Simulation, DES > Results > View Application Delay Tracking,
and DES > Panel Operations > Reload Data Into All Panels.

- Removed DES > Results > Compare Results.

- Updated Choose Results dialog box.

- Removed IER Editor chapter (functionality now accessible via
System Editor’s IER Database menu) and renumbered chapters.

- Removed references to the Scenario Conversion Module.
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Product
Release Date Version Chapter Description of Change

March 30, 2006 6.1 Final 3 - Updated Traffic Flow Preferences dialog box figure to reflect
checkbox options design.
- Removed “Rename Scenarios “feature from Manage Scenarios
section.
- Added Import Scenario > TNAPS to XML.
- Removed Import Scenario > From Visio.
- Added shortcut keys for configuring/viewing TSSP circuits.
- Added Configuration Utilities > Multiplexer > Configure
Multiplexer Circuits and View Multiplexer Circuits.
- Noted the default username and password for the IER database.

Appendix A - Removed Multiplexer Utility Nodes section.

March 3, 2006 6.1 Draft 2 - Updated System Editor and Sign-in figures to reflect version 6.1.
- Added Edit > Preferences > Device Model Map > (options).
- Removed Help > Generate Support Info.
- Renamed Help > Error Log > View as Help > Error Log > Open.
- Renamed Help > Message Log > View as Help > Message Log
> Open.
- Added Help > Session Log > (options).

3 - Updated “Deploying Satellite Links” section to reflect new
tabbed design of Satellite Bent Pipe Link Deployment dialog box.
- Updated TSSP Circuit Deployment dialog box figure (and
corresponding text description) to reflect new tabbed design.
- Updated View TSSP Circuits dialog box figure (and
corresponding text description) to reflect new column names.
- Removed Traffic > Convert Traffic > Flows to IERs.

4 Added Edit > Preferences.

5 - Updated figure (and text) to reflect name change from “Icon
Editor” to “lcon Database”, and new toolbar buttons.
- Added File > Exit.
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Product
Release Date Version Chapter Description of Change
November 14, 2005 5.2 Final Front material Changed refs in Documentation Conventions section to be

NETWARS-specific rather than OPNET-specific (i.e, changed
<opnet_user homex\... ref to <NETWARS
path>\Scenario_Builder\...)

2 - Added statement (“Please contact NETWARS CM to register
your license.”) to Starting License Manager section.
- Changed Express method description to “(Requires authorized
access.)” in Adding a License section.
- Updated Task Tracking Workflow GUI figure.

3 - Updated Edit > Project Defaults > IER figure.
- Updated View > Visualize Link Loads > Color by Link Load
figure.
- Updated View > Network Views > Logical figure.
- Added Map > Background > Add CADRG/CIB Raster catalog
directories.
- Renamed Scenario > Scenario Documentation as Scenario >
Set Scenario Documentation.
- Corrected ref to old command (Topology > Import > Subordinate
Response) in Scenario > Import Scenario > Subordinate
Response.
- Updated Object Palettes to include Tree view and reflect new
icons.
- Updated Annotation Palette.
- Removed Topology > Link Operations > Deploy TSSP Groups.
- Added Deploying Satellite Links section.
- Added Topology > Configuration Utilities > TSSP > Configure
TSSP Groups (Circuits.)
- Added Topology > Configuration Utilities > TSSP > View TSSP
Group Configs (Circuits.)
- Updated Topology > Import Device Configuration Files.
- Removed Advanced Traffic Wizard.
- Updated Traffic Wizard figure.
- Removed Traffic > Convert Traffic > Link Loads to Flows.
- Removed Traffic > Convert Traffic > Open Conversion Log.
- Removed Traffic > Convert Traffic > Clear Conversion Log.
- Updated Terrain > Edit Parameter Sets figure.
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Document Revision History

JCSS Technical Reference Manual

Product
Release Date Version Chapter

Description of Change

October 10, 2005 5.2 Draft All

3
File menu

Edit menu

- Updated document footers and applicable screenshots to reflect
new NETWARS version number.

- Added (optional) Server Characterization and Mainframe
Characterization options to System Editor (File > Open Editor.)

- Added Edit > User Level options.

- Updated Figure 2-4 (Open Editor dialog box) to reflect addition
of (optional) Server and Mainframe Characterization editors.

- Updated Figure 2-9 (Security Classifications dialog box) to
reflect addition of Set Default button.

- Updated Figure 2-11 (Advanced Preferences dialog box) to
reflect new prefs and correct CORE version in title bar.)

- Removed figure of License Manager Help dialog box (not
necessary to document since Help changes with each version.)
- Added Previous Editor and Circulate Editors options to Windows
menu.

- Added Help > Documentation > User’s Guides options.

- Removed references to ‘demands’.

- Updated File > Close Project to reflect that both the project and
the Scenario Builder window close (instead of the project only.)
- Updated Figure 3-6 (Briefings dialog box) to reflect addition of
Add Logical View button.

- Added Figure 3-7 (Print Preview dialog box.)

- Renamed File > Package as File > Package Project Files, and
old File > Package submenu ‘Project Files’ as ‘Project’.

- Added File > Recent Projects (with submenu) to replace old list
of recent projects.

- Removed File > Close Scenario Builder.

- Renamed File > Exit NETWARS as File > Exit.

- Renamed Edit > Select All in Subnet as Edit > Select All.

- Added Edit > Find Node/Link.

- Renamed Edit > Select as Edit > Group Selection/Action >
Selection Filter

- Renamed Edit > Apply Action as Edit > Group Selection/Action
> Action Filter

- Renamed Edit > Object Palette as Topology > Open Object
Palette

- Renamed Edit > Annotation Palette as Topology > Open
Annotation Palette

- Moved Edit > Device Model Map submenu to Edit > Preferences
> Device Model Map.

- Added Edit > Preferences > Device Model Map > Open.

- Renamed Edit > Defaults > Device Model Map as Edit >
Preferences > Device Model Map > Choose.

- Removed Edit > Defaults > Demands, Edit > Defaults >
Bandwidth Requirements, and Edit > Defaults > Application
Conversion.
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Document Revision History

Product
Release Date Version

Chapter

Description of Change

View menu

Map menu

Scenario menu

- Added View > Show Scenario Treeview.

- Added View > Layout > Geographic Positioning.

- Added View > Layout > Layout Nodes Automatically (Balanced).
- Renamed & moved View > Edit Visualization Preferences to
View > Layout > Edit Display Preferences.

- Renamed & moved View > Zoom In to View > Zoom > To
Rectangle.

- Renamed & moved View > Zoom to Selection to View > Zoom
> To Selection.

- Renamed & moved View > Zoom Out to View > Zoom >
Unzoom.

- Renamed View > Redraw as View > Refresh Workspace.

- Removed View > Network Views > Organization Systems and
View > Network Views > Device Systems.

- Renamed View > Network Views > Logical Views as View >
Network Views > Logical.

- Renamed Figure 3-42 (View Filtering dialog box) as Logical
View Selection dialog box & added detail to dialog box options.
- Renamed & moved View > Set View Properties to Map >
Background > Set Properties.

- Added View > Visualize Protocol Configuration > IP Tunnel
Configuration.

- Renamed Map > Set Area of Operations as Map > Set Area of
Interest.

- Replaced Figure 3-45 (Set Area of Operations dialog box) with
new Set Area of Interest dialog box.

- Updated Figure 3-46 (Setting background view properties) to
reflect addition of Translucency column and Edit CADRG/CIB
Properties button.

- Replaced Figure 3-47 (Set Area of Operations dialog box) with
new Choose Border Map dialog box.

- Renamed Map > Background > Import Image as Map >
Background > Add Image Map.

- Renamed Map > Background > Import Background Image as
Map > Background > Add Image.

- Removed Map > Background > Import JMTK Data.

- Renamed Map > Background > Import MIF Data as Map >
Background > Add MIF Map.

- Added Figure 3-50 (MIF Import Log dialog box.)

- Updated Figure 3-57 (Define Trajectory dialog box) to reflect
changes.

- Added Figure 3-58 (Trajectory Segment Information dialog box.)
- Added Scenario > Manage Scenarios and Figure 3-64 (Manage
Scenarios dialog box.)

- Removed Scenario > Remove Scenario.

- Renamed Scenario > Import as Scenario > Import Scenario.

- Renamed Scenario > Import > NETWARS Scenario as Scenario
> Import Scenario > From NETWARS.
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Product
Release Date Version Chapter Description of Change

- Renamed Scenario > Import > OPNET Modeler Scenario as
Scenario > Import Scenario > From OPNET Modeler.

- Renamed Scenario > Import > Scenario from XML as Scenario
> Import Scenario > From XML.

- Renamed Scenario > Import > Scenario from Visio XML as
Scenario > Import Scenario > From Visio.

- Removed Scenario > Export > Export to HTML.

- Renamed Scenario > Export as Scenario > Export Scenario.

- Renamed Scenario > Export > Scenario to XML as Scenario >
Export Scenario > To XML.

- Added Scenario > Export Scenario > To JNMS.

- Renamed Scenario > Export > Scenario to Visio XML as
Scenario > Export Scenario > To Visio.

- Renamed Scenario > Summary Tables as Scenario > Reports.
- Renamed Scenario > View Task Organization Report as
Scenario > Reports > Task Organization.

- Added Scenario > Reports > User-Defined Reports > Open Live
Report Table and Scenario > Reports > User-Defined Reports >
Generate Report from Template.

- Added Scenario > Generate Scenario Web Report and Scenario
> Generate Scenario Bitmap.

- Added Figures 3-87 (Generate Scenario Web Report dialog
box), 3-88 (Displaying Scenario Web Report in Web Browser),
and 3-89 (Model Image Capture Preview dialog box.)

Topology menu - Added Topology > Open Library Treeview and Figure 3-95
(Library Treeview.)
- Renamed Topology > Device Creator as Topology > Create
Custom Device Model.
- Renamed Topology > Import > Subordinate Response as
Scenario > Import Scenario > Subordinate Response.
- Renamed Topology > Export > Subordinate Response as
Scenario > Export Scenario > Subordinate Response.
- Added Topology > Link Operations > Deploy TSSP Groups and
Figure 3-101 (TSSP Circuit Deployment.)
- Removed Topology > Link Operations > Redeploy Link.

Traffic menu - Added Traffic submenus for Traffic Wizard, IERs, Flows,
Device/Link Loads, and Convert Traffic.
- Added descriptions of Traffic Wizards (Simple & Advanced.)
- Removed Traffic > Collector Import Settings and Traffic >
Visualize submenus.
- Renamed Traffic > IER/Demand Import Options as Traffic >
IERs > Set Import Options.
- Renamed Traffic > Specify Demands as Traffic > IERs > Specify
IERs.
- Added Traffic > IERs > Import from IER Report.
- Renamed Traffic > Visualize > Export Traffic Report as Traffic >
IERs > Export IER Report.
- Added Traffic > IERs > Export IERs to XML.
- Renamed Traffic > Import Flows > (options) as Traffic > Flows >
Import > (options).
- Renamed Traffic > Create Traffic Flows as Traffic > Flows >
Create Flows.
- Replaced Create Traffic Demands dialog box in Figure 3-132
with Create IP Unicast Traffic Flows dialog box.
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Document Revision History

Release Date

Product
Version

Chapter

Description of Change

Protocols menu

NetDoctor menu

DES menu

Windows menu

Glossary

- Renamed Traffic > Visualize > Open Flows Browser as Traffic >
Flows > Open Flows Browser.

- Renamed Traffic > Visualize > Export Traffic Flows as Traffic >
Flows > Export to Spreadsheet.

- Updated Figure 3-139 (Export Traffic Flows dialog box.)

- Renamed Traffic > Import Device/Link Baseline Loads >
(options) as Traffic > Device/Link Loads > Import > (options).

- Removed Traffic > Convert NETWARS Applications to
Demands.

- Renamed Traffic > Convert Applications to Flows as Traffic >
Convert Traffic > Applications to Flows.

- Updated Figure 3-140 (Convert Applications to Flows dialog
box) to remove Time Step settings.

- Renamed Traffic > Convert Link Loads to Flows > Configure/
Convert as Traffic > Convert Traffic > Link Loads to Flows.

- Renamed Traffic > Convert Traffic Flows to NETWARS
Demands as Traffic > Convert Traffic > Flows to IERs.

- Renamed Traffic > Convert Link Loads to Flows > Open
Conversion Log as Traffic > Convert Traffic > Open Conversion
Log.

- Renamed Traffic > Convert Link Loads to Flows > Clear
Conversion Log as Traffic > Convert Traffic > Clear Conversion
Log.

- Added Traffic > Generate Traffic Web Report.

- Renamed Traffic > Visualize > Visualization Aggregate Traffic
Preferences as Traffic > Set Aggregate Traffic Preferences.

- Renamed Traffic > Collector Import Settings > Specify
Core/Edge Devices as Traffic > Specify Core/Edge Devices.

- Added Protocols > LDP, Protocols > RSVP, Protocols > VLAN,
and Protocols > STP.

- Removed Protocols > MPLS and Protocols > DPT.

- Updated Figure 3-149 (Terrain Data Directory Preferences
dialog box) to reflect addition of Format drop-down list and
support for terrain data type ‘OpenFlight’.

- Updated Figure 3-151 (Import Elevation Lines dialog box) to
reflect reorganization of dialog box fields, etc..

- Updated Figure 3-153 (Evaluation Settings dialog box) to reflect
reorganization of dialog box buttons.

- Added NetDoctor > Auto-Generate Report Template...,
NetDoctor > Suppress Messages, NetDoctor > Rule
Development..., and NetDoctor > Options.

- Removed NetDoctor > Security.

- Removed DES > Record Animation for Subnet.

- Added DES > Record Packet Flow Animation for Subnet and
DES > Record Node Movement Animation for Subnet.

- Removed DES > Color Links by Utilization.

- Removed DES > Clear Link Visualization.

- Removed DES > Panel Operations > Export Panels > To HTML.

- Added Previous Editor and Circulate Editors options to Windows
menu.

- Removed ‘Demands’ from Glossary.
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Product
Release Date Version Chapter Description of Change
April 1, 2005 5.1 Final Cover Changed release date to April 1, 2005, and removed OPNET
contact info from Identification section.
March 21, 2005 5.1 Final 1 - Added ACE to ACE Whiteboard section.
2 - Added ACE option to System Editor (File > Open Editor.)
2and 3 - Corrected definition of functional names in Edit > Preferences >
Functional Profiles.
3 - Added View > Zoom to Selection and View > Layout options.
- Added Scenario > New/Duplicate/Previous/Next Scenario.
- Updated Figure 3-18 to reflect new button placement.
February 21, 2005 5.1 Final No changes.
February 7, 2005 5.1 Draft All Ported existing Word document (NETWARS v 4.2) into Adobe

FrameMaker 7.1, and applied commercial OPNET product
documentation style template to improve quality and update
manual. Reformatted text as needed to fit new format and style.

Content changes:

- Updated applicable screenshots to reflect new NETWARS
version number.

- Added reference to ACE doc in chapter 1, and added ACE
Whiteboard option to System Editor (File > Open Editor) and
Scenario Builder (Traffic > Import Flows.)

- Removed Capacity Planning > Restore Link Colors and
Capacity Planning > Show Link Legend.

- Removed Alternate Link Cost field from Capacity Optimization
Settings Advanced Parameters dialog box.
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JCSS Technical Reference Manual 1—Introduction

1 Introduction

Editor Interfaces

System Editor

The JCSS Technical Reference Manual is a comprehensive reference and
guide that covers all aspects of JCSS operation and use. It contains over 200
figures that provide visual examples of the JCSS interfaces, step-by-step
procedures, and other important JCSS features and concepts.

Organization of the chapter topics is menu-based, meaning topics are grouped
and ordered according to the various menus and menu options available in the
respective JCSS interfaces.

The capabilities of the JCSS software are organized into separate editors:
* The System Editor,
e The Scenario Builder, and

* Other optional editors that require an extra license (To learn more about
available editors, refer to the IT Guru documentation suite.)

The System Editor acts as an entry point to the remaining editors. It allows you
to access user and profile information as well as the task assistant interface.

Scenario Builder

The Scenario Builder allows you to build template OPFACs and organizations,
define infrastructure and Information Exchange Requirements (IERs) between
OPFACs and organizations, specify movement and geographical context for
OPFACs and organizations, and run discrete event simulations for developed
scenarios. You can open and work with multiple projects simultaneously, and
easily cut, copy and paste supported objects (Organizations, OPFACs, devices,
links, etc.) between them.

Additionally, the Scenario Builder provides you with the option of deploying a
communications infrastructure using a top-down approach. More specifically,
the Lead Planner sets up the planning view and sends the initial scenario to the
Subordinate Planners. The Subordinate Planners modify their portion of the
initial plan and then send it back to the Lead Planner who integrates them into
a complete plan.

JCSS/Release 7.0
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The Scenario Builder allows you to optimize link and broadcast network
capacities as well as traffic load. The optimization of the link and broadcast
network capacities is implemented by changing the size of links and broadcast
networks while the optimization of the traffic load is implemented by changing
the load caused by the IERs.

This editor also allows you to view results of the simulation. After the simulation
is complete, the Simulation Domain creates text files that capture the results of
the simulation. The Scenario Builder reads these files and displays the results
graphically as Measures of Performance (MOPs). The MOPs focus on the
ability of selected communication equipment to send and receive information
(e.g. file transfers, situation awareness updates, e-mail messages, etc.).

TR-1-2
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2 System Editor

2—System Editor

The System Editor is the editor that opens first when you start JCSS. From the
System Editor, you can open any of the other JCSS editors, like the Scenario

Builder. The System Editor allows you to access user and profile information, as
well as the task assistant interface.

Accessing the System Editor

Starting up the JCSS software launches the System Editor and a Sign In dialog
box, as shown below.

#|NETWARS 2007 Portions copyrighted by OPNET Technologies, Ine - Ol x|
File Edit License IER Database ‘Windows Help

Fortions pmotected by LS. Patants & 278 253 and 6,820,042

Figure 2-1 System Editor
|
Profile
E Local Administrator ﬂ

New. |  Edt. |

2007 Sign In I Exit | Help |

Figure 2-2 Sign In dialog box

JCSS/Release 7.0
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1) By clicking the New button in the Sign In dialog box, the system launches
the New Profile dialog box as shown below. The * designates a required
field and must be filled-in to continue the sign-in process.

_loix

Last Mame * ||

Firzt Mame * I tdiddle [nitial I
Title I

Organization * I

NIPRNET Email |

SIPRNET Email |

Fhone I

T actical Phone I

Street Addiess |
=]

¥ Usze Task Assistant at Startup

* = Required Figld oK Cancel |

Figure 2-3 New Profile dialog box

2) Enter required information and any optional information. Click OK.

JCSS will save up to five (5) user names so that multiple users can use the
software without re-typing their user information. This information is used to
track the changes made in the scenario by the planner. The Subordinate

Planners also use this information when they need to send the subordinate
response files back to the Lead Planner. If you have logged in before, select
your name from the drop-down menu. To enable the Task Assistant to open
upon sign-in, ensure that the Use Task Assistant at Startup is checked.

3) The Sign In dialog box displays again with the new user name in the Profile
field. Sign in by clicking the Sign In button or, if you elect to edit your profile,
you may do so at this time by clicking the Edit button.

TR-2-2 JCSS/Release 7.0
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File Menu

—+#|NETWARS 2007 Portions copyrighted by OPNET Technoloe -0l x|
File Edit License IER Database ‘Windows Help

Mew Project., .. kvl
Open Project... Chrl+0

Cpen Subordinate Query. ..

Mew Other, ..
Cpen Other. ..

Manage Madel Files

Recent Projects

Exit NET'WARS

Fortions pmtected by LS. Patents 9 278 62, and 6,020,042,

|

Figure 2-4 System Editor’s File menu

New Project File > New Project...: Opens a new Scenario Builder and displays the Create
Project dialog box. Create a new project, the first step in the Lead Planner’s
workflow. You can simply name and launch a generic project, or use the New
Project Wizard to select and set the area of operations, top-level units (including
their locations and templates), an equipment list for each organization, an owner
for each unit, and the types of equipment to use in the new project.
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1) Specify the names for the project and the initial scenario in the Create
Project dialog box.

iﬁ-]l:reate Project |
To create a new project, pou muzt ;l Project M ame: ||

specify a name for the project and the
firzt scenano. The clazsification zetting
will appear in the project editor at all
times.

Scenario Mame: Ihaseline
If "Launch Mew Project Wizard" iz
checked, the new project wizard will start
after you chck OF.

;I Clazsification: I Idnclassified j
v Launch Mew Project 'Wizand (] I Cancel |

Figure 2-5 Creating a new project

2) Select a classification level for the project in the Create Project dialog box.

3) Click OK. If Launch New Project Wizard is not checked, then JCSS
creates a generic project using the names you have designated. If Launch
New Project Wizard is checked, then JCSS displays a sequence of dialog
boxes that enable you to make selections specific to your new project.

Note—The names for both the project and the scenario cannot contain any
spaces or special characters. In addition, the scenario name cannot be the
same as any existing OPFAC; it must be unique.
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Open Project

Open Subordinate
Query

New Other

Open Other

File > Open Project...: Displays the Open Project dialog box in which you can

select a project file to open, and then opens the selected file in a new Scenario

Builder.

1) Navigate to the NETWARS Project directory, and select the .prj file
corresponding to the project that you wish to open.

Lok in: Ia zerGuide_CP_Scenario j = Eii v

0 UserGuide_CP_Scenario
. UserGuide CP_Scenario. pri

example_netw...

File name: ILlserGuide_CF'_Su:enariu:u j Open I
j Cancel |
e

Filez af type: IF'roiect Files [* prjl

Figure 2-6 Opening a Project in Scenario Builder

File > Open Subordinate Query...: Displays the Open Subordinate Query
dialog box in which you can select a query file to open, and then opens the
selected file in a new Scenario Builder.

File > New Other...: Displays the New dialog box which lists standard OPNET
editors from which you can select to create.

x
I lcon Database il

Figure 2-7 New dialog box

File > Open Other...: Displays the Open dialog box which lists standard OPNET
files from which you can select to open.

JCSS/Release 7.0
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Manage Model
Files

Manage Model
Files > Delete
Model Files

Manage Model
Files > Add Model
Directory

Manage Model
Files > Refresh
Model Directories

Recent Projects

Exit NETWARS

File > Manage Model Files > (option). This submenu lists options which allow
you to manage model files.

File > Manage Model Files > Delete Model Files...: Displays a list of models
from which you can select to delete files.

'—LZ-]DEIEI:E Models ﬂ

Select model[z) to delete:

[&CE Application T azk Characterization [ atc.m] Iﬂ
ACE Diff Config File [ ace. diff)
ACE Filter Definition [ ace.f)
ACE Host Mapping [.ace.hm)
ALCE Protocol Dictionary [.ace_dict)
Acrobat File [Online Help) [ pdf)
Analysiz Configuration [.ac)
Animation Hiztory [.ah)
Antenna Pattern [.pa.m)
Automation Settings File [.af]
Background map image [.map.i]
Background map image [.bka.i)
Browzer Arrangement Config File [ nbac]
C Include File [ k)
C++ Inchude Filz [ hpp)
Cartographic Data Set [.cdz)
Comma-Separated Values Data File [Lcav]
Core Mode Selection Plugin Definition File [ .chapf]
Cuztom kaodel List [oml)
Cuztam Madel List Exclusions [ cml exc)
DES Information [.dezinfo)
[rata Dizplay Model [.dd.m)
Demand Model [.demand.m)
Derived Demand Model [ demand.d)
Derived Link Madel [lk.d)
Derived Mode Model [.nd.d)
Derived Path Model [ path.d] ﬂ

| TP 1L T UG PRI o SR R (PP P S |

Delete... LCancel |

Figure 2-8 Delete Models dialog box

File > Manage Model Files > Add Model Directory...: Displays the Directory
Browser in which you can create a new directory for models.

File > Manage Model Files > Refresh Model Directories: JCSS maintains a
list of folders called the model directories (or mod_dirs for short) where the
models are stored. Models include OPFACs, organizations, projects and
scenarios, icon databases, and device models. When you move such models
around on the hard drive using Windows Explorer, the software does not
recognize the change. To make the software aware of the changes, use this
option.

File > Recent Projects > (option): This submenu lists recently opened projects
for easy re-opening.

File > Exit NETWARS: Exit NETWARS.

TR-2-6
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Edit Menu

—+#|NETWARS 2007 Portions copyrighted by DPNET Technologies, Ine - 0] x|

File | Edit License IER Database ‘Windows Help

Login Information
Change User. ..

User Level

Preferences

L W
SN

<)

2007 OPNET

Mgk g i s Pt
Fortions potected by LS. Patents ©,278 D523 and 8,820,042,

|

Figure 2-9 System Editor’s Edit menu

Login Information Edit > Login Information: Edit user profile information.
1) After modifying profile information, click OK.

Change User Edit > Change User: Change the current signed in user and sign in information
at any time by using the System Editor.

1) To change the user’s profile, choose the user’'s name from the drop-down
menu, as shown in the figure below.

sclectuser

Select User E Local Adminiztrator i

0. I LCancel |

Figure 2-10 Select User dialog box

2) Click OK when modifications are complete.
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User Level

User Level >
Beginner

User Level >
Intermediate

User Level >
Advanced

Preferences

Preferences >
Device Model Map

Preferences >
Device Model Map

> New...

Edit > User Level > (option). Switch between JCSS interfaces (simple to
complex) by selecting one of the available User Level options. JCSS menus
change to reflect the selected User Level. Higher User Levels display more
menu items and menu headers. You can switch between User Levels at any
time, so that all menu items can be available if you so choose. Switching the
User Level affects all open editors.

Edit > User Level > Beginner: Select this User Level to access a simplified
JCSS interface. The Beginner interface hides access to many of the
functionalities of the system without removing the capabilities themselves. This
results in an interface that is reduced in complexity, and is easier to navigate for
beginner JCSS users.

Edit > User Level > Intermediate: Select this User Level to access a JCSS
interface that exposes more functionalities of the system than the Beginner
level, but less than the Advanced level. This results in an interface that is
reduced in complexity, and is easier to navigate for intermediate users.

Edit > User Level > Advanced: Select this User Level to access the
full-featured JCSS interface. The Advanced interface exposes all of the
functionalities of the system. This results in an interface that is more complex,
and best utilized by more experienced JCSS users.

Edit > Preferences > (option). Display and edit JCSS preference settings.

Note—These menu options perform the same functions as the Preferences
options under the Edit menu in the Scenario Builder.

Edit > Preferences > Device Model Map > (option). Set default device model
map files.

Edit > Preferences > Device Model Map > New...: Using the Choose Source
and Target Model Name Lists dialog box, select the paths to where you want
new source and target model list .txt files to reside, and then click OK.

iﬁ-]l:huuse Source and Target Model Name L

Source Model List: I C:A\Metwars\User_Datahzource_list b=t Browze. ..

U

Target b odel List: | C:A\Metwars\User_Datahkarget_list. bt Browsze...

ok I LCancel |

Figure 2-11 Choose Source and Target Model Name Lists dialog box

TR-2-8
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Preferences > Edit > Preferences > Device Model Map > Open...: Using the Device Model
Device Model Map Map Browser, navigate to and select an existing JCSS device model map .xml
> Open... file to open, and then click Open.

Device Model Map Browser 2=l

Look in: Ia ser_Data j = EF Ef-

IER_Text_Files
OPFACs
Organizations
Palettes
Projects

Rules

SE_Data
Terrain Daka
Traffic_Data

File narne: || j Open

Files af type: IDevice Model b aps [*.=ml] j Cancel |
E

Figure 2-12 Device Model Map Browser

Preferences > Edit > Preferences > Device Model Map > Choose...: Using the Device Model
Device Model Map Map Preferences dialog box, navigate to and select a device model map .xml
> Choose... file to import into JCSS as needed, and then click OK.

ﬂDE\'iEE Model Map Preferences

[mport b ap; I

Browze. ..

[k

Expart Map: Ier'ﬂ 2.0 A netwars rules\ MBS _Output_ap sml Browsze. .

ok I LCancel |

Figure 2-13 Device Model Map Preferences dialog box
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Preferences >
Functional Profiles

Preferences >
Geographical
Coordinates

Edit > Preferences> Functional Profiles: Set default functional profiles and
functional names. Every OPFAC has one or more functional names. A
functional name maps an IER or series of IERs to a producer/consumer OPFAC
pair. A collection of such functional names is called a functional profile. A
functional profile can be defined locally on an individual OPFAC, or globally, so
that it is available to all OPFACs and across different scenarios.

iﬁ-]Fum:tiunal Profile ﬂ

Prafile: ESampIe :I

Hew. .. I Bename... Remove... |

Functional Mams | Type Al
AMSALCS E wplicit
IF202 E wplicit

Iheert Delete
ok I LCancel |

Figure 2-14 Functional Profile dialog box

1) Add, rename, or remove functional profiles as needed.
2) Insert, delete, or edit functional names as needed.

3) Click OK.

Edit > Preferences> Geographical Coordinates: Sets the default
geographical coordinate system view displayed in the workspace of the
Scenario Builder. There are three types of geographical coordinate systems
available in JCSS: Lat/Long, UTM, and MGRS.

_|ol x|
Select Geographical Coordinates for Units:
% Lat/Lang

" UTM
" MGRS

| iﬁ-]Gengraphical C =

LCancel |

Figure 2-15 Geographical Coordinates dialog box

1) Select the Lat/Long, UTM, or MGRS radio button.

2) Click OK.

TR-2-10
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Preferences >
Owners List

Preferences >
Security
Classifications

Edit > Preferences> Owners List: Set owner information for units marked for
subordinate query.

=10/ x]

Last Mame | Firgt Mame | Title | Organization ﬂ

Baroni Fhillip bd ajor lDIS.t‘-\

Oitiz Tito bd &jor DISA

q _'l_l
bdd | Deke | ok | Carcel |

Figure 2-16 Owner List dialog box

Owner information contains four fields: Last Name, First Name, Title and
Organization. All fields, except the Title field, are required fields.

* Modify existing records or add/delete records to the list as needed.

Edit > Preferences> Security Classifications: Set security classification for a
variety of items in a scenario, such as devices and IERs. This dialog allows you
to add, remove, or change values in the list of recognized security classification
values. The list is used to populate drop-down lists in edit fields and table cells
that specify security classification values. Since some fields and cells only allow
values from this list, you will need to modify this list in order to specify custom
security classifications. Any value is permitted, although duplicates are not
allowed in the list.

The list order indicates the classifications’ levels of restriction. Less restrictive
classifications appear toward the top of the list.

iﬁ-]Security Classifications x|
DEFAULT |
Confidential
Secret
Top Secret
K| _'I_I
Up | Do |nzert | Delete | Set Defaul |

Save I

Figure 2-17 Security Classifications dialog box

LCancel |
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A value in the list may be modified by selecting and editing it. The Up button
moves the selected value toward the top of the list. The Down button moves the
selected value toward the bottom of the list. The Insert button inserts a blank
entry above the selected value. The Delete button deletes the selected value.
The Set Default button sets the selected classification as your default. The
Save button saves all changes. Once saved, the changes will affect all edit
fields and table cells, but the values stored in those attributes will not be
modified.

Preferences > Edit > Preferences> Traffic Flow Thresholds: Specify a minimum value and
Traffic Flow the colors to be used for each threshold; traffic flow thresholds are used in
Thresholds conjunction with the Aggregate Traffic Flows feature. Flows are colored based

on the threshold they fall under. If the load of an aggregate flow is more than the
highest threshold, the flow is colored black. If the load is lesser than the
minimum threshold, the flow is not displayed. The default minimum value is 0
Kbps.

:—iﬁ:—]Trafﬁc Flow Thresholds _ i
Traffic Load Calor

Finirnrn: 0.a00
Wihite: -
Threzhaold 1: 2.000

ellow -
Threzhold 2 4.000

i

Green
Threshold 3: 10,000

Blue
Threshald 4: 20,000

Red

Lol Lo

Threshold 5 500.000

Help... |

Figure 2-18 Traffic Flow Thresholds dialog box

ERRRKA

Cancel

:

e Set desired traffic load/color combinations, and then click OK.
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Preferences > Edit > Preferences> Advanced: View and/or set environment attributes, or
Advanced “preferences”, that control program operation. These values are stored in the
environment database file (env_db for short).

i—]Preferences Editor - C:\NETWARS_Z2007"Scenario_Builder'op - |EI|5|
Search for: || IAnywhere kd
Arrange by I Groups Rl I Advanced view
| Mame |Va|ue ;I
o |
ADNY
ACE
Autamation Destroy Decorations at End TRUE
Dashbaard Display OFPNET averlay in 3D Visuglizer  FALSE
Dezign Action 2 Earth G i Madel ioht <ok
Discrete Event Simulati - ar. EUC'_EH "C_ noe rnght_spnere
Export E ntity tapping Library ophet_3dnyv_default_ma
Impart HLA Fed File Mamne <hull>
Licensing HLA Federation M ame OPMET_30MY
Mizcellaneous Launch 30 MNetwork Yizualizer FALSE
NETCOP Launch 30MY Communication FALSE
MetDiactor b apping Library I nitislization Argument <l -
Froduct Performance
Froject Editor ﬂ | C
HEDC'_”'HQ ) — Preference Infarmation
Terrain Modeling RS LIEIaY ror ERry LIesman ;I
Traffic ;
Troublezhooting Walue: 1 J
Ul
irtual CLI
A p— Dezcription: Mumber of seconds to wait between the creation of
LI | FTI ohjectz and the generation of the objects' initial -
ar LCancel Apply Help

Figure 2-19 Sample Preferences Editor

1) Use the Seach for field (and drop-down list) to search for preferences that
contain specific words or values (Anywhere specifies to search Tags,
Names, Values and Descriptions; In Names specifies to search Tags and
Names only; In Values specifies to search Values only.)

2) Use the Arrange by drop-down list to display preferences by category
(Groups specifies to arrange preferences by group; Source specifies to
arrange preferences by source.)

3) Check (or uncheck) the Advanced view checkbox to toggle between
showing an advanced or basic view of the preferences table (basic view
shows the name and value of each preference; advanced view shows the
name, tag, source of the preference’s value and the value itself.)

4) Edit desired preference values by clicking in the corresponding Value cell,
selecting or typing the new value, and then pressing the <Enter> key on
your keyboard.

5) Click OK to save edits and close the Preferences Editor.
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License Menu

+#|NETWARS 2007 Portions copyrighted by DPNET Techno o [mf

File Edit | License IER Database ‘Windows Help

License Managermenk
Product Modules

Fortions pmotected by LLS, Patents & 278 053, and &,820,042.

|

Figure 2-20 System Editor’s License menu

License Management

License > License Management: A license conveys the right to use an
application. A single license typically bundles one or more applications (such as
Modeler), the simulation program, and one or more modules.

Licenses are allocated on a per-component basis. A component that is part of a
license (perhaps a module such as TMMGUI) may be free and can be given to
any requester, even if another component of the same license (most likely an
application program) is in use.

License Terminology

* Add license — Add a license to the machine’s license file.

* Deregister License — Remove a license from a machine’s license file (it is
then free to be installed on a different machine).

* License — Authorization to use an OPNET product.

* License Manager — Software interface for performing license operations.
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License Server — A service running on a machine that will distribute licenses
to other computers.

Revoke License — Free a license that is currently in use.

Standalone Mode - A licensing mode in which only the local machine can
obtain the licenses.

License Attributes

License Files

License number — Specifies the software license. A single license may
bundle several programs (for example, 100/1 that includes the programs IT
Guru, Expert Service Prediction, and Multi-Vendor Import will be shown as
three separate lines in the License Manager interface.)

Program name — Specifies which programs are included in the license (such
as IT Guru and the Radio module).

Status - Identifies the state of the program.

— A free program (shown in green) is available to the next user who
requests it.

— An in use program (shown in white) is unavailable.

— An expired program (shown as yellow with red X) is no longer valid.

License expiration — Displays a date or the word “permanent,” depending
on the type of license purchased.

Maintenance expiration — An expiration date. It is not possible to buy
perpetual maintenance.

User — Shows the user ’s name if the license is in use.

Host — Shows the machine where the license is being used.

Files for dedicated licenses (as opposed to floating licenses) are stored in the
OPNET _license directory.

Note—When it is time to install a new version of the software, do not delete the
license files.

Starting License Manager

The License Manager can be accessed from the Start Menu or the System
Editor. If you need to perform license maintenance, it is better to access the
License Manager from the Start Menu (JCSS does not need to obtain a license).

Note—Please contact NETWARS CM to register your license.

JCSS/Release 7.0
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* To access License Manager from the Start Menu, simply select it from the
Start/Programs/NETWARS/License Manager menu option.

* To access License Manager from the System Editor, select it from the
License menu.

i—]License Manager: Requested server: cons_licserver on pork_3 = |D|ﬂ
File Edit Tools Modules windows Help

License servers iee;

EI-. Reguested server [cong_liczerver, port_a) ﬂ Add License
—  Running comectly.

— Running a current or compatible releaze.
— ‘Windows MT 5.0 Build 2195

— 11.0.4 PL1 [Build 2900

Stop Server

Set az Default Server

F—  Security - Some access restictions are not in Clear Licenze File
— Host P address iz 172.16.10.48 —
| Spstem date is Sep 27 2005, Uiz Syt Lilie

— Licenze file path iz [CAOPHET _licensehlicens
FH  License file (200 licenses)
Local servers Help Export Tree |

WTN11239 [port
Oth [pt:.r' _IT:! ik You are looking at information about ~|

51 SBIVEIS 0N s NS the: license Server process running on

Conf-Crunch [parta) Yanf-Crunch”.

FORD [part_a]

GRIMMA [port_a] This server is on a remote machine,

RIDCULLY [port_a) contacted over your network,

TRILLIAM [port_a]

WTNTI184 [part_a) | |The server process appears to be -
Kl | LIJ i) . ’ _>l_|

Figure 2-21 License Manager: Requested Server dialog box

The License Manager contains details about the license server that you
requested during the installation of JCSS. The License Manager also provides
a Help menu that can be accessed by clicking the Help button.
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Adding a License

Product Modules

1) Click the Add License button on the License Manager to display the
Choose Transaction Method dialog box.

iﬁ—][huuse Transaction Method x|

'ou have four methods for completing your reguest:

1] Express - automatic, via the Internet

2] Browser - through a web browszer [uze if Express method does naot wark]
3Email - exchange codes with OPMET via email

4] Offline - exchange codez with OPMET wvia telephone or fax

Express I Browszer Email Oftline LCancel

Figure 2-22 Choose Transaction Method dialog box

There are four transaction methods:

e Express — Automatic via the Internet (Requires authorized access.)

* Browser — Through a Web browser if the Express method does not work.
e Email — Exchange Codes with OPNET via Email.

» Offline — Exchange codes with OPNET via Telephone or Fax.

License > Product Modules: Select active modules. Product Modules refer to
additional licensed OPNET functionality. For example, JCSS uses the Terrain
Modeling Module GUI (TMMGUI) and Multi-Vendor Import (MVI) product
options, which are licensed under the NETWARS license. (JCSS can also make
use of NetDoctor and Simulation licenses to further enable the JCSS-resident
functionality.)

If a module is deactivated using this option (by deselecting the checkbox next
to a module name) the corresponding features of that module will not be active
in JCSS. For example, the Terrain menu will not be available in JCSS if the
TMMGUI module is deactivated.

JCSS/Release 7.0

TR-2-17



2—System Editor JCSS Technical Reference Manual

IER Database Menu

—#|NETWARS 2007 Portions copyrighted by OPNET Techn -10] x|
File Edit License | IER Database ‘Windows Help

Choose Current Database. ..
Edit...

Mew, .,
Duplicate. ..
Merge...
Compare, ..,

Change User
Manage Accounks

S FIIIII\‘l W

Mg g gy g Ao aioes Peciarm”

Fortions protected by LS. Patents 6 272,962, and 6,820,042,

|

Figure 2-23 System Editor’s IER Database menu

Database Selection

By default, JCSS will install a database service. The name of the service would
be the hostname of the system followed by \NW2004_1. JCSS allows users to
select between multiple databases on the local server or to select any network
accessible database server as a datasource.

Choose Current IER Database > Choose Current Database: Choose the current database
Database server and database within that server for use as a default data source for the
IER Editor. Each selected server requires login for a user account registered at
that database server, so you may be prompted for a login when changing the
selected server.

TR-2-18 JCSS/Release 7.0



JCSS Technical Reference Manual 2—System Editor

Edit

New

Duplicate

Merge

Compare

Change User

IER Database > Edit...: View and edit IERs in the IER Database Editor table.
This table will contain the current working set of IERs, which you may view,
insert into, delete from and modify. The current working set contains IERs that
have been queried from the database, imported from text files, or entered
manually.

i.-]lER Database Editor Table =
Current [ER::
IER ID || |..|Produce| Type |Eonsumer Type | URC |Elasslflcatlon ‘ Perizhability [2] | Plecedencﬂ Traffic |Avg. Size [sf. |Equwpment Dist Typpe ;I
Platoon_Leader JTF_OPFAC Unclassified ROUTINE Computer
2 Platoon_Leader JTF_OFFAC Unclazzified IMMED 1A, Computer
3 Platoon_Leader JTF_OFFAC Unclazzified IMMED 1A, Computer
4 Platoon_Leader JTF_OPFAC Unclazzified FRIORITY Computer
5 Platoon_Leader JTF_OPFAC Unclazzified IMMED ... Computer
B JTF_OPFALC Platoon_Leader Unclazzified FRIORITY Computer
T JTF_OPFALC Platoon_Leader Unclazzified IMMEDIA... Computer
g JTF_OPFALC Platoon_Leader Unclazzified ROUTIME Computer
9 JTF_OFFAL Platoon_Leader Unelassified IMMEDIA... Computer
10 JTF_OFFAL Platoon_Leader Unelassified FLASH Computer =
< | _'I_I
*- |IER has been modified by the user Im Edi...
Add | Delete/Undelete Bevert Oimit Ot All Copy Impart.... | Expart... | Gluery.. | Save to Database.. |
LCloze

Figure 2-24 |ER Database Editor Table

IER Database > New...: Create a new database on the specified server.
Creating a database requires Administrator access, so you will be prompted for
an administrator login. Logging in as the administrator also selects the
destination server.

Database names cannot contain spaces or duplicate an existing database
name on the selected server. Differences in capitalization are not enough to
make database names unique; for example, Database1 is considered the same
as both database1 and DATABASE1.

IER Database > Duplicate...: Copy/duplicate the current default database. If no
default database has been selected, you will be required to select one. You will
also be required to provide a Database Administrator ID and password for the
destination server. A new database will be created, and its name must be
unique as described above. The newly created database will contain copies of
all of the records in the source.

IER Database > Merge...: Merge one database into another. All of the records
from the source database will be copied into the destination database. Any
existing records in the destination database whose identifier fields match
records in the source database will be overwritten by the source records.

IER Database > Compare...: Produce a record-by-record comparison report for
two selected databases. The resulting report can be in text or HTML format.

IER Database > Change User: Clear all retained user passwords; requires you
to login again to the default database server.

JCSS/Release 7.0
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Manage Accounts

Manage Accounts

> Admin

Manage Accounts

> User

IER Database > Manage Accounts > (option). Database Administrators have
the authority to create databases or accounts, or to modify passwords or
account access permissions. Administrator access allows control over any
database or user account on a specified server.

Database users may read the contents of database tables and store changes to
them. Users only have access to selected databases. When users login to a
server, they will be given the list of databases on that server that they are
allowed to access.

User accounts may differ for each database server, so switching servers may
require a new login.

IER Database > Manage Accounts > Admin: Manage JCSS administrator
accounts.

IER Database > Manage Accounts > User: Manage JCSS user accounts. rant
or deny access to designated servers and databases, add and delete users, and
change user passwords via the Database User Account Management dialog
box shown below.

x
Server: I j
Database: I Ll
Granted Access Denied Access
Change Pasaward... | Add... | Delete... |
Cloze |

Figure 2-25 Database User Account Management dialog box

Password Retention

User logins are retained for the duration of the session until you select to change
the user. For typical operations, password retention will minimize repetition of
password prompts. JCSS will not retain administrator passwords. Each time a
user conducts an administrator operation, JCSS will ask for the administrator
login.

TR-2-20
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Windows Menu

+#|NETWARS 2007 Portions copyrighted by OPNET Technol —|ol x|

File Edit License IER Database | Windows Help

Previous Editar Chrl+H,
Circulake Edibors  Chrl+]

Hide This Editor
Hide Cther Editors
Show Al Editors

|

Figure 2-26 System Editor’s Windows menu

Previous Editor Windows > Previous Editor: Make the previously displayed editor the current
editor.

Circulate Editors Windows > Circulate Editors: One at a time, make each open editor the
current editor.

Hide This Editor Windows > Hide This Editor: Hide the current editor. If another editor is open,
that editor is made the current editor.

Hide Other Editors Windows > Hide Other Editors: Hide all open editor windows except the
current one.

Show All Editors Windows > Show All Editors: Re-display any hidden editors.
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Help Menu

—#|NETWARS 2007 Portions copyrighted by OPNET Technologies, The =101 x|
File Edit License IER Database ‘Windows | Help

Task Assistant

Docurnentation

Shave &ll Logs.. .

Error Log
Message Log k
Session Log

About NETWARS

e

2007

Portions pmotected by LS. Patents 5,278 2532, and &,820,042,

Figure 2-27 System Editor’s Help menu

Task Assistant Help > Task Assistant: Display a list of workflows available to the planners. A
workflow is simply an outline of steps to guide the planner through the flow of
tasks associated with the particular mission being addressed.
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The Task Assistant dialog box is shown below. The treeview on the left hand
side of the dialog box shows the list of workflows available, and the explanation
for those is provided in the pane on the right.

#|NETWARS - Task Selection =10l =]
“Workflows E splanation
— ME TWw/a RS Intraduction ;I The Tazk Azsistant has several workflows that are designed to ;I
| | = S guide the user through the steps necessary to plan, analyze,
: ol oLl and simulate a communications data/voice netwark. The
= Tazk Azsistant Uzer Tupes Taszk .-’-‘«s_sistant workflows_are a sequence of uger instructions
= Crisis Action Planner that define the steps required to a_ccomphsh fundamental
= . . . . METWARS tasks. The Task dssistant workflows are
&| Rapid Scenario Building and Analysiz cantained in a unique window that can be moved or minimized
| Operational Planner on the screen. The Task Agsistant Workflow windows contain

a checklist of azsociated steps on the left side, with ingtructions

5] ic.ati 4 4 5 B
B Develop Communications Flan and uzer annotation on the right side. Mot all of the steps in

©l| Create Response to Communications Plan Query the warkflow are required, so a green "R for required or blue
= Analyst "0" far optional will guide the user through each step of a

& AnabeeC ications Perf workflow.  Additionally, tasks defined as milestone tasks are

8| Analyze Lommunications Performance marked with a red "M Both required and optional tasks can
= JHMS User be designated as milestone tasks. A uzer can define a specific

task az a milestone task by nght-clicking on a task and
selecting Task Tracking Info from the selection menu, More

18| Develop Communications Plan with Equipment List k™

8| Pertorm Capacity Planning Analysis detailz regarding the Tazk Tracking function are available in
8| Perform Configuration Management = the azzociated Help button. Once a step is completed, double
= _I—I click on the step and a check mark will replace the green "R"
LI | 4 or blue 0", Additional kelp for the Task Assistants is available ﬂ
Help... [~ Shiow At Startup Start Workflaw LCloze |

Figure 2-28 Task Assistant dialog box

The list of workflows displayed in the Task Assistant dialog box are organized
based on categories of user tasks and most recently used workflows.

1) To start a workflow, first select the workflow and then use either the Start
Workflow button or simply double-click the workflow of interest.

2) To review the items within each workflow, click the plus sign to the left of
the workflow category. This expands that category as shown below.

W ork Flow
BN D evelop Communications Plan

M| Create a new project

=M Define the Mizszion
— R Anzwer Mizsion Analysiz Questions
=0 Add Mission Analysis Duestion
—0| Delete Mizsion Analpsiz Question
0| Export Mizsion Analysis [nformation
[=HM| #dd Orgarizations and OPFACs
El-l"."l Add Organization
R| £dd Organization from Object Palette
R| Add Organization fram T reeview

Figure 2-29 Expand a workflow category
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Assume that you have decided to develop a communications plan. You would
select Develop Communications Plan by double-clicking the icon to the left of
the text. This calls the Develop Communications Plan task.

—K|NETWARS - Task Assistant B ] A
ok flows E xplanatian
Bl Cevelon Communications Plan ! Thiz workflow shows the Operational planner how to develop ;I
M| Create a new project a communications plan in a zemi-collaborative Joint Planner
M Define the Mizsian Erwironment. The Develop Communications Flar workflow

utilizes the Scenano Builder editor az the primary uzer

R/ Answer Mission Analysis Questions interface. Additional information regarding the functionality of

O/ Add Mizsion Analysis Question the Scenario Builder editor can be found in the NE TWARS
O/ Delete Mission Analysis Question Users Manual. To view the NETWARS Users Manual,
0| Export Mission Analysis Information please select the Help Menu and select the "Users Manual.

[=FM| &dd Organizations and OPFACs
M Add Qrgarization

M Add OPFAC

M Develop Mew OPFAC
Define Planning Links

Define Connectivity Links
Review Requirements M atrix

Define Additional Time Phazes or Courzses of Action

Export Queries to Subordinates LI
Import Subordinate Response File l” _'I
Define Dev.lc:e Application Profiles Annotation

Usze Capacity Planker to Analyze Plan ;I

Simulate the Metwork Plan
Save and Close Flan

Analyze Results -
b I
| Export | [ Shaow Milestones Close |

Figure 2-30 Develop Communications Plan task

In the figure above, each line item of the workflow has a letter to the left of the
text indicating whether it is a milestone (M), an optional (O) or a required (R)
task. In addition, many of the tasks can be expanded, by clicking the plus sign
to reveal details on what steps are necessary to complete each task.
Additionally, each line of the workflow is supplemented by details on how to
complete that task in the Explanation pane located on the right side of the Task
Assistant dialog.

TR-2-24
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1) If you do not find the workflow of interest, choose the Browse for Workflow
option under the Recent Workflows in the Task Assistant dialog box to
locate the desired workflow.

H|NETWARS - Task Selection il o [ 3
ok flowes Explanation
METWARS Introduction d The Browse for Workflow function gives you the ability to ;I
Task Assistant D escription navigate the file system to find and resume workflows. The
Task Assistart User Types warkflows are lacated in the zame directory as their associated
= Dperational Planner project. Their names are of the form

"¢ project_names -workflow. xml”. Double-click on the “Browse

&l Develop Commurnications Plan for wharkflow..." entry bo start locating & workfow,

[&l| Create Responze to Communications Plan Cuery
[=F = | Crisiz Action Planner

[&l| Evaluate and Optimize High Level Communications F
=] Analyst

8| &nalyze Communications Performance
[FHE| Recent workilows

¥ UseGuide_DE_Scenario:Develop Communications |
I8 Fircze for Workflow.

g a o g

Help... [ Show &t Starbup Start Wwharkflom

Lloze |

Figure 2-31 Task Assistant browse for workflow

2) If you chose not to use the Task Assistant workflows, exit by clicking the
Close button.

Task Tracking

This feature, available from the Task Assistant, provides you with the capability
to track timeline, dates due, milestones, and percent done for the planning tasks
associated with the plan being developed.

1) Task tracking information is available from the Task Tracking dialog box.
Right-click on a particular task or on the workflow in the Task Assistant, and
select Task Tracking Information. If you click on the workflow name and
select Task Tracking Information, the workflow dialog box launches.

2) Check the Edit Workflow Time Information and enter the number of days
for the entire workflow.
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3) Click OKto save changes and close the dialog box. The figure below shows
workflow time information.

=TE

Wfarkflove Explanation
S5l Develop Communicati Thizs workflow shows the Dpelatmnal planner how to develop ;I

Create a Mew Project

7] I a commumcatlons plan |n a sem| collaboratwe Jairt Planner
= e g Plan wark flow
M| Define the Mission ﬁTask Tracklng Infur - |EI|_| rimary uger
it the: functionality of
M| Add Organizations and OFFACs Edit Workfow Time |nformation . H?e LﬁnECTI$;|I:‘ySD
M Defing Planning Links sers Manual,
M| Define Connectivity Links Enter nurber of days for the entire warkflow ual.
M Werify Link Comsistency Mumber of dags: |45
M Review Fequirements M atis | LI
0| Define Additional Time Phases ar Courses of Actian ok I Cancel | _'I
O Export Queries to Subordinates
O Import Subardinate Pesponse File PEEL J
0O Defing Device Application Prafiles
0| Use Capacity Flanning Features to Analyze Plan
M Simulate the Metwnrk Plan hul
4 » -
Help.. | Export | I- Show Milestones Cloze |

Figure 2-32 Entering number of days for the entire workflow

4) Right-click on a task and choose Task Tracking Information to launch the
Task Tracking dialog box, as shown below.

—+|NETWARS - Task As =lolx]
Work_flow :—L:Z-]Task Tracking Inform = |E||5|
[=HEl| Develop Communications Plan Ew project in the I
Create a new project Percent Task Completed: I 0, Asmgn an
Diefing the Mission in the Enter
Add Qrganizations and OPFACs Edit Milestone Information——————————
Define Planning Linksz ¥ Specify as Milestane

Defing Connectivity Links : .
Rewview Requirements Matrix Sipizelly sl Wit
Define Additional Time Phases or Courses of Ac | Das ta finish [fram start)
Export Queries to Subordinates !

Import Subardinate R esponse File Help... | oK | Cancel I ;I
Define Device dpplication Profiles LI
Use Capacity Planner to Analyze Plan T
Simulate the Metwork Plan

Save and Clase Plan :I
Analpze Rezults

K| _'I_I =l
Help... | Expart | [ Show Milestones Close |

—] =

Anhotation

M
M
M
M
M
0
0
0
0
0
M
M
M

Figure 2-33 Task Tracking dialog box

The Task Tracking dialog box shows the milestone information, and the percent
task completion. The Task Tracking dialog box provided above shows that the
task Create a New Project is a milestone task (also known from the “M” icon for
this task). The task is currently 50% complete. It has a task weight of 1, and days
to finish (from start of the workflow) is 1.

5) To edit this milestone information, check Edit Milestone Information. You
can then change task weight and days to finish.
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6) Update the percent task completed accordingly.

—#|Task Tracking Infurn'f' -0l x|

Percent Task Completed: | 100.0

v Edit Milestone Infarmation

v Specify as Milestane
Specify Task YWeight:
D ays to finish [from start):|5

Help... | LCancel | OE. I

Figure 2-34 Editing milestone information

—_

A particular task can be completed by setting its task completion percent to 100
(from the Task Tracking dialog box, as shown above), or by double-clicking the
task from the Task Assistant. When a milestone task is completed, the icon in
the Task Assistant dialog box changes from “M” to display a check mark.

In order to complete a milestone task, all of its required and milestone sub-tasks
need to be complete. If they are not complete, you will be prompted to do so.
Similarly, a completed task can be marked incomplete, either by entering a
value for task completion percent that is less than 100, or by double-clicking the
completed task from the Task Assistant dialog box.

In the figure below, task Define the Mission is complete (as indicated by the
check-mark), and percent task completion is set to 100 in the Task Tracking
Information dialog box.

| =loix
Workflow Explanation
EHE| Develop Eommunlcanons Flan & 156t the framemark for the rlaneing process by defining the _ﬂ
ﬁTask Tracking Informea -_:5' = |0} x| p series of questions
Anal_l,ls_|s. '_I'he qL_Aes_tlons
b .-'-‘-.nswer Mizsion Analpsiz Questions  Percent Tazk Completed: |1DD.D acilegz;-n?-:‘;‘:ctllc‘lar:{dhdclsoﬂ't:rg’l
0| Add Migsion Analysis Question o ’ :
O/ Delete Mission Analysiz Question (I Edit Milestane Informatian
0| Export Miszion Analysis Information W Specii as ilestone
M Add Organizations and OFFACE _
M Define Flanning Links e Bl I
M| Define Connectivity Links Days ta finish (from start) i ;I
M Review Requirements Matris _Lj
O/ Define Additional Time Phases or Cours Help... | (] 4 | Cancel I
0! Export Queries to Subordinates
0 Import Subordinate Fesponze File = ."_I
0| Define Device &pplication Profiles
0 Use Capacity F'Ianner to Anal_l,lze Plan =
—‘I 1 1IRA SN iy | PO, o P ' _.‘l_l ;!
Help... | Expart I [ Show Milestarnes Close I

Figure 2-35 Completing a task
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Documentation

Documentation >
User’s Manual

Documentation >
Technical
Reference Manual

Documentation >
Software Release
Bulletin (SRB)

If a milestone is overdue, it is flagged with a red “X”.

#|NETWARS - Task Assistant - o ] [
‘wiorkflow Explanation
EHE| Develop Communications Plan ;I To develop a METWARS scenario, a user must add ;I
v Create a new project orgahizations and OPFACs that represent their
1 Defing the Miszion caormmuhications plan. Drganizations are groupings or
P4 #dd Organizations and OPFACs OPFACs that can represent military organizations or a
o ' G = I — k it physical location. OPFAC: are the fundamental building
UGSl efIB 1.8 blocks for a METWARS scenano, NETWARS OPFALCSE are
R DE“'?E EUnnEFllVllP Links ) groupings of communication device models [CDMz] that are
~/ Review Requirements kb atriz azzociated with & unit. Faor example, an OPFAC may
0| Define &dditional Time Phases or Courses of &ction represant the communications assetz associated with a tank
0| Export Queries to Subordinates or airplane.
0| Import Subordingte Fesponze File ;I
0| Define Device &pplication Profiles ﬂJ _pl
0| Use Capacity Planner to Analyze Flan .
0| Simulate the Network Plan Annatation
Rl Save and Close Plan ;I
0O fnalyze Results
-
B » o
Help... | E rport | [~ Show Milestones Cloze |

Figure 2-36 Overdue milestone

1) Toggle the milestone display on or off using the Show Milestones
checkbox at the bottom of the Task Assistant. This will display/hide the
completion percentage and days remaining for the milestone tasks, and for
the entire workflow. The completion percentage for the entire workflow is
calculated as a function of the completion percentage of each of the
milestone tasks, and their relative task weights.

2) By clicking the Export button, you will be prompted for a filename and
location to save the task information as a tab-delimited text file. This file can
be opened in MS Project (choose Default Task Information for the Import
Mapping when opening the file).

Help > Documentation > (option): Access the JCSS documents discussed
below:

Help > Documentation > User’s Manual: Open the JCSS User’s Manual using
Adobe Acrobat Reader. Acrobat Reader software can be optionally installed
with JCSS. The JCSS User’s Manual is a guide that covers basic aspects of
JCSS operation and use. It contains figures that provide visual examples of the
JCSS interfaces, step-by-step procedures, and other important JCSS features
and concepts.

Help > Documentation > Technical Reference Manual: Open this document,
the JCSS Technical Reference Manual, using Adobe Acrobat Reader.

Help > Documentation > Software Release Bulletin (SRB): Open the JCSS
Software Release Bulletin using Adobe Acrobat Reader. Acrobat Reader
software can be optionally installed with JCSS. The SRB contains release notes
for the current version of JCSS.

TR-2-28
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Documentation >
NETWARS
Acronyms

Documentation >
IT Guru
Documentation

Show All Logs

Error Log

Error Log > Open

Error Log > Clear...

Message Log

Help > Documentation >SNETWARS Acronyms: Open the NETWARS
Acronyms table using Adobe Acrobat Reader. Acrobat Reader software can be
optionally installed with JCSS. The NETWARS Acronyms table contains
definitions for acronyms commonly used with JCSS.

Help > Documentation > IT Guru Documentation: Open the complete IT
Guru document set. IT Guru is an OPNET commercial-off-the-shelf (COTS)
product that models the behavior of networks—many JCSS features are based
on IT Guru features. In this JCSS Technical Reference Manual, many
references will ask you to access the IT Guru documentation for further details
on certain features.

The IT Guru documentation contains a global index and a search query feature
that enables you to quickly find needed information.

Help > Show All Logs...: Launches the Log Viewer.

SI=TE
Dizcrete Event Simulation | Miscellanenusl
Logs Selected Log
ACE_whiteboard =] Catege] [ ] Date Time | Event | =
Simple_application_Lhai BIEP |1 150501 0ct08 2007 D 210 Networ

12 16:05:01 Oct 08 2007 640686043375 10274 MNebwort
13 16:05:01 Oct 08 2007 131817041642 90130 Nebworl
14 16:05:01 Oct 08 2007 7200 1833363 Nebwort
5 16:05:01 Oct 08 2007 1834067 <MAa:

Simple_Condition_Fulfillr
Simple_Dizcovery
Simple_FTP
Simple_Goto_Decizion
Simple_Goto_Decizion_*
Simple_Meszzage_Queui
Simple_Mode_aAttibute
Simple_Mode_State
Simple_Tirmer
Simple_lser_Defined S

e o aegerle o

Open Advanced Viewer Close | Help |

[ | Digplay loas for curent scenario anly

Figure 2-37 Log Viewer

Help > Error Log > (option): If errors occur during the operation of JCSS, they
are logged in this error log file.

Help > Error Log > Open: Using this menu option, you can open the error log
file to view the error messages in a text editor.

Help > Error Log > Clear...: Clear the error log file of the selected range of error
messages.

Help > Message Log > (option). Status updates that monitor the performance
of JCSS are logged in this message log file.

JCSS/Release 7.0
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Message Log >
Open

Message Log >
Clear

Session Log

Session Log >
Open

Session Log >
Clear...

About NETWARS

Help > Message Log > Open: Using this menu option, you can open the
message log file to view the status messages in a text editor.

Help > Message Log > Clear: Clear the message log file of all status
messages.

Help > Session Log > (option): Basic file operations during the current session
are logged in this session log file.

Help > Session Log > Open: Using this menu option, you can open the session
log file to view the session messages in a text editor.

Help > Session Log > Clear...: Clear the session log file of the selected range
of session messages.

Help > About NETWARS: View information about the OPNET core software
version, the models version, and copyright information.

TR-2-30
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3 Scenario Builder

The Scenario Builder is the JCSS interface for creating, modifying, and saving
projects and scenarios; it allows you to develop a complete communications
plan.

The Scenario Builder is also used to evaluate and optimize network
performance. Given a network and the traffic, it runs the optimization and comes
up with suggestions for optimal link and network capacities.

Additionally, this interface analyzes the results of a simulation session. It
converts output from a simulation session into data that is viewable and grouped
into Measures of Performance (MOPs).

Accessing the Scenario Builder

When you choose to either open an existing project in JCSS or create a new
project, the Scenario Builder displays.

:—ii-]Scenariu Builder: UserGuide_CP_Scenario Scenario: LUsers -10| x|
File Edit “iew Scenarios Topology Traffic Protocols  Capacity Planning DES  Windows  Help

B E LI R =T
Uil assified 0 -
]
45
CFH.DATA
EFHDATA 2
E._-ii E-:ii CFH-ICE
JFLCC CF
JFLCC-OICE
]FS_Q_C(;//
T e
Unelassified -
K r o

| [370238N 002581 2E

Figure 3-1 Scenario Builder
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File Menu

New Project

Open Project

File > New Project: Opens a new Scenario Builder and displays the Create
Project dialog box. Create a new project, the first step in the Lead Planner’s
workflow. You can simply name and launch a generic project, or use the New
Project Wizard to select and set the area of operations, top-level units (including
their locations and templates), an equipment list for each organization, an owner
for each unit, and the types of equipment to use in the new project.

1) Specify the names for the project and the initial scenario in the Create
Project dialog box.

i—][reate Project ]
To create a new project, you must ﬂ Project Marme: ||

gpecify a name for the project and the
firzt scenano. The clazsification setting
will appear in the project editar at al
times,

Scenario Mame: Il:naseline
If "Launch Mew Project Wizard" is
checked, the new project wizard will start
after pou click OF.

;I Clazsification: I Urclazsified LI
v Launch New Project ‘wizard (] I Cancel |

Figure 3-2 Creating a new project

2) Select a classification level for the project in the Create Project dialog box.

3) Click OK. If Launch New Project Wizard is not checked, then JCSS
creates a generic project using the names you have designated. If Launch
New Project Wizard is checked, then JCSS displays a sequence of dialog
boxes that enable you to make selections specific to your new project.

Note—The names for both the project and the scenario cannot contain any
spaces or special characters. In addition, the scenario name cannot be the
same as any existing OPFAC; it must be unique.

File > Open Project or click the Open an Existing Project toolbar button:
Displays the Open Project dialog box, and then opens the selected project in a
new Scenario Builder.

TR-3-2
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Save Project/
Save Project As

Open Subordinate
Query

1. Double-click on the project folder of interest and select the corresponding
.prj file.

2

Look in: Ia gerGuide CP_Scenario j L= |=j‘fE v

1 UserGuide_CP_Scenatio
I_Iser'Euiu:IE _P_Scenario.pri

File name: ILIserG uide_CP_Scenario j Open I
Files of type: IF'miect Files [ pri] j Cancel |
F

Figure 3-3 Opening a Project in Scenario Builder
To create a new project, click the Create a New Project button.

File > Save Project or File > Save Project As: Save changes to existing
projects in the Scenario Builder by using either the Save or Save As option.

1) To save the changes you made to an existing project in the Scenario
Builder, select the Save option.

OR

1) To save the changes you made as a separate project in the Scenario
Builder, select the Save As option.

2) Specify the desired name in the subsequent dialog box, and then click OK.
File > Open Subordinate Query: Displays the Open Subordinate Query dialog

box, and then opens the selected subordinate query file in a new Scenario
Builder.

1) The Subordinate Planner will be prompted to select the appropriate file to
be edited. Select the file by double-clicking on it.

JCSS/Release 7.0
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2) The project that you select will then open in a new Scenario Builder. The
green “e” icon on top of the units indicates that the Senior-level Planner has
marked these units to be edited by the Subordinate Planner. Other units
that have a red lock icon on top indicate that the Subordinate Planner may
only view these units and cannot edit them. Lock units are hidden by default
upon opening.

3) To view all units, select View > Filter > Restore Full View.

_OPRACZ

JTF_DPRACT

/LS

k.angas City

JTF_PlatoonLeader JTF_OPFAC3

Figure 3-4 Opened Subordinate Query

The Subordinate Planner also has the capability to export subordinate query
files, allowing this process to be repeated through many levels of hierarchy.

Save Subordinate File > Save Subordinate Query: Save the Subordinate Planner’s changes to
Query the subordinate query file.

Close File > Close: Close the open project or subordinate query file.

1) You will be prompted to save your project. Choose the desired option.

iﬁ-]l:luse Scenario Builder ﬂ

Do you want to zave the changes you made to
'UzerGuide_CP_Scenano’ ?

Dan't Save | LCancel |

Figure 3-5 Closing a Project

The selected project and its Scenario Builder window close.
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Generate Scenario File > Generate Scenario Briefing: Export scenario information directly to a
Briefing PowerPoint (.ppt) file. Customize the briefings by selecting desired components
from a set of elemental briefing components.

A graphical user interface (GUI) is provided to enable you to choose the briefing
components that you want to include, and then generate the briefings.

=181x]

Explanation

Select fram the available ;I
components. Checked-off
componentz will be included

it the presentation.

i

—|i Conterts
—|i E=ecutive Summary Placeholder
Scenanio Documentation

—|i Object Summary |
+ |_ Metwork, i

|_ M etwork, Object Wiew

|_ Systemsz Wiew -
4 ; -

Save Briefing...l Launch Eriefing LCancel |

Figure 3-6 Briefings dialog box

1) Choose from the available components shown on the left hand side of the
dialog box. The explanation of the selected components displays on the
right hand side text box. Some of the components may not be available and
will be shown disabled in the dialog box accordingly.

2) After selecting the components, choose Launch Briefing or Save
Briefing.

a) Launch Briefing launches the PowerPoint application and opens the
briefing generated.

b) Save Briefing prompts you to specify a filename and location for saving
the briefings PowerPoint file.

Page Setup File > Page Setup: Displays the Print Setup dialog box from which you can set
printing options.
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Print Scenario File > Print Scenario: Prints the contents of a JCSS scenario. A preview of the
scenario displays as it will appear when it is printed.

When the scenario is printed, the contents of each subnet are printed on a
separate page. Every page has a default header, which is the hierarchical name
of the subnet.

“#|Print Preview =101 %]
Header: Ik: UserGuide_CP_Scenario-UserGuide_CP_Scenario [Submet top]  Set Header | Page 1 of 22
I~ | Frint wisible area only

v ‘white background {* Scale image directly

Fage Setup I Frew Page | Mext Page

LCloze |

[+ Fit to single page " Adjust For printer resolution

Heework: TsorGuile_CF_ficens rio-Tser Guils_UF_ficena riv [iubnec: top]

i e >
ST e
- [ g ¥, B
y - iy Sy
i
1 -+ l_’f -
I'y -
T -.ﬁ" e

Figure 3-7 Print Preview dialog box

1) From the preview, browse through the pages and make choices about the
following:

a) Set the header to be used on each printed page

b) Use the background color as it appears on the workspace, or click the
White background checkbox to use a white background.

c) If you check Fit to single page, the contents of a subnet print in one
page; if not, each subnet prints across multiple pages. The total number
of pages displays at the top right corner of the preview window.

d) Choose to either scale the image directly, or adjust for printer resolution.

e) Click Page Setup if you want to select the mode (landscape or portrait),
paper size, etc.

2) Click Print, and select the desired printer.
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Print Graphs File > Print Graphs: After you have defined and displayed graph panels, you
can print the visible graphs.

Refresh IER Text File > Refresh IER Text Files: IERs are queried from various sources; text files
Files are one of them. Text files are queried when you view the IERs for an OPFAC
or run a simulation. If changes are made to the text files, they are not
immediately reflected in the scenario that is currently loaded in the Scenario
Builder. In such cases, you can use this menu option to force the list of IERs to
be refreshed.

Manage Model File > Manage Model Files > (option). This submenu lists options which allow
Files you to manage model files.

Manage Model File > Manage Model Files > Delete Model Files: Displays a list of all models
Files > Delete from which you can select to delete files.

Model Files
—+#]Delete Models x|

Select model(z] to delete:

[ACE &pplication T ask Characterization [ abe.m) | =
ACE Diff Config File [ace.diff]
ALCE Filter Definition [.ace.f]
ACE Hozt Mapping [ ace.bim]
ACE Pratocal Dictionary [ ace_dict]
Acrobat File [Online Help) [.pdf]
Analyziz Configuration [Lac)
Animation Hiztary [.ah]
Antenna Pattern [.pa.m]
Autamation Settings File [ af]
Backaround map image [.map.i]
Backaround map image [ bko.i]
Browser furangement Config File [.nbac)
C Inciude File [.h]
C++ Include File [ hpp]
Cartographic Data Set [Lods]
Comma-Separated Values Data File [ oev]
Care Made Selection Plugin Definition File [ cnepf]
Custorn Model List [ cmil]
Cuzton Model List Exclugions [ cml exe)
DES Information [ desinfa]
Data Dizplay Model [.dd.m)
Demand tadel [.demand.m]
Derved Demand Model [ demand.d)
Derived Link Model [ k.d)
Derived Mode Model [ nd.d]
Dierived Path Model [ path.d] |

Delete. .. LCancel I

Figure 3-8 Delete Models dialog box

Manage Model File > Manage Model Files > Add Model Directory: Displays the Directory
Files > Add Model Browser in which you can create a new directory for models.
Directory
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Manage Model
Files > Refresh
Model Directories

Recent Projects

Package Project
Files

File > Manage Model Files > Refresh Model Directories: JCSS maintains a
list of folders called the model directories (or mod_dirs for short) where models
are stored. Models include OPFACs, organizations, projects and scenarios,
icon databases, and device models. When you move models around on the
hard drive using Windows Explorer, the software does not recognize the
change. To make the software aware of the changes, use this option.

File > Recent Projects: This submenu lists recently opened projects for easy
re-opening.

File > Package Project Files: Provides you with the ability to package and
import JCSS data files. It serves as a convenient mechanism to exchange JCSS
data with other users, and with NETWARS Support.

There are different options for including different files in the package. These
various options are available from the Package Project Files menu. Four
different options are available for packaging the files; and there is one menu
item for importing packaged files.

A zipped archive is created as a result of choosing one of the package menu
items. The zipped archive contains the following files for the various options:

* Project — Project, scenario, subordinate query, traffic, trajectory, OPFAC
and organization files, simulation model files (if they exist.)

* Project with Simulation Results — Project files as indicated in the Project
Files option and simulation results files.

* Project for NETWARS Support — Project files as indicated in the Project
Files option and other files needed by NETWARS Support (env_db files,
various log files etc.).

e Custom OPFACs and Organizations — All OPFAC and organization files
under the Custom OPFACs and Custom Organizations folders.

To import package file, choose Import from the Package Project Files menu. A
file chooser is presented to browse for the zipped archive containing JCSS files.
After you select the archive file to be imported, a dialog box with the different
import options displays (see figure below.)

iﬁ-]lmport Package Files

]

|F archive file names conflict with existing file names, then:

£+ Do nat ovensrite any existing files
" Beplace all existing fles

£ Prompt separately for each of the conflicting files
LCancel |

[v Save backup copies of files being replaced

Figure 3-9 Import Package options
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Edit Menu

Exit

Undo

Redo

Backup copies of files being replaced are created by default. You can turn that
off by un-checking the check box in the above dialog box.

If you choose to be prompted for each file separately, then for every conflicting
file, a dialog box displays. From this dialog box, you can choose to not overwrite
the existing file, to replace the existing file, or to quit the import process.

Info-ZIP’s Zip and UnZip1 are used to create and import the zip file.

File > Exit: Shut down the entire JCSS program. If there are editors that are
open, you will be prompted to save the contents of those editors. When all open
editors have been acknowledged and closed, the software is shut down.

Edit > Undo: Undo editing operations.

Only the following actions can be undone:

* Adding a unit (includes OPFAC and organization), device, or association
(includes intra OPFAC link, inter OPFAC link, satellite link, broadcast
network, relationship and circuit) from the palette or library.

* Moving a unit, device, association, or any group of these objects in the
workspace.

* Deleting a unit, device, association, or any group of these objects in the
workspace or using Scenario Builder treeview.

* Modifying attributes on devices; all attribute changes made while the Edit
Attributes dialog box is open will be considered a single action.

Some actions may prevent certain, or all, prior actions from being undone (for
example, saving a project file.) Immediately following a save to disk, there will
be no undoable actions.

There is no limit on the number of actions that can be undone; however, the
actions can only be undone in the reverse order in which they were performed.

Edit > Redo: Redo the undone operations. The actions can only be redone in
the reverse order in which they were undone, which means that the last undone
action will be the first one to be redone.

1. Copyright (c) 1990-1999 Info-ZIP. All rights reserved. "Info-ZIP" software is provided "as is," without warranty of any kind, express or
implied. In no event shall Info-ZIP or its contributors be held liable for any direct, indirect, incidental, special or consequential damages
arising out of the use of or inability to use this software. Info-ZIP retains the right to use the names "Info-ZIP," "Zip," "UnZip,""WiZ," "Pocket
UnZip," "Pocket Zip," and "MacZip" for its own source and binary releases.
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Any action (editing operation which includes add, delete, move, modify)
performed after performing Undo will clear the Redo stack, and the undone
operations cannot be redone.

Cut Edit > Cut : Cut selected, supported objects on the workspace to the clipboard,
and remove them from the workspace. If unsupported objects are attached to
a supported object, then the unsupported objects are also removed from the
workspace but not maintained on the clipboard.

Supported Objects:

Organizations

OPFACs

Devices

External links

Internal links

Satellite links

Broadcast networks
OPNET demand objects

Unsupported Objects:

Radio links

Circuits

Relationships

OE

Configuration OPFAC

Copy Edit > Copy: Copy selected, supported objects on the workspace to the
clipboard.

Supported Objects:

Organizations

OPFACs

Devices

External links

Internal links

Satellite links

Broadcast networks
OPNET demand objects

Unsupported Objects:

Radio links

Circuits

Relationships

OE

Configuration OPFAC
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Paste Edit > Paste: Paste all objects on the clipboard to the workspace.

Delete Edit > Delete: Delete the objects selected on the workspace.

1) Select the objects that need to be deleted. To select multiple objects, press
the <Ctrl> key on the keyboard while clicking on the objects.

2) Once the objects are selected, use this menu option or use the <Del> key
on the keyboard to delete them.

3) Confirm the deletion.

Select All Edit > Select All: Select all the objects in the current subnet. Once the objects
are selected, perform edit operations (like move, delete, etc) on these objects
as needed.

Find Node/Link Edit > Find Node/Link: You can search for an object (such as a node,
subnetwork, link, or path) based on its name (part or all of the name.) Every
object whose name contains the string you specified is selected and listed. Or
you can leave the search field blank to find all objects in the network.

—+#]Find Node,/Link x|

Marme contains: Il‘ﬂag

ame Subnet M ame Type ;I
MAGTF Mw_Top Hode J
MAGTF-DATA MNw_Tap Hode

MAGTF-OICE Mw_Taop MHode

CFH-MAGTF Mw_Taop Lirk.

JFMCC-MAGTF Mw_Taop Lirk. ;l

[ |gnaore views

Lozate Hodedlink Eind I Cloze Help |

Figure 3-10 Find Node/Link dialog box

1) Enter a text string in the Name contains field to search for specific names.
Leave this field blank to find all objects in the network.

2) Click Find. Found objects are highlighted in the display (any objects in the
display that were previously highlighted are de-selected.)

The Find Node/Link dialog box displays a list of the seached objects,
including their names, subnet names, and types.

3) Select the name of an object in the list, and click Locate Node/Link. The
display changes to locate and highlight the seleted object.

JCSS/Release 7.0 TR-3-11



3—Scenario Builder JCSS Technical Reference Manual

Group Edit > Group Selection/Action > Selection Filter: Select multiple objects
Selection/Action > based on their attributes.
Selection Filter
1) Select the type of object by clicking the appropriate check box.

2) Choose the attribute to be used for selecting objects from the drop-down
menu. The list of attributes changes dynamically with the type of objects
chosen for selection. From this list, select one or more attributes and
specify the matching criteria. If there are objects of the selected type that
match the attribute selection criteria specified, they are marked as selected.

—#]selection Filter x|
Object Type:
[~ Organization [~ Relationship [~ Intemal Link [~ Radio Link
[~ Opfac I~ Metwork [~ Ezternal Link. [~ Planning Link
[~ Device [~ IER [~ Satellite Link
]
FROP it Mame = WAL UE =]
=

Delete |

Selection Mode: ¢ Reselect % Select {7 Deselect

aK Cancel

Figure 3-11 Selection Filter dialog box

The table used for specifying the matching criteria has four columns.

— PROP - If set to Require, an object must satisfy all attribute criteria for
selection; if set to Consider, an object must satisfy at least one of the
attribute criteria for selection.

— Attr Name — Name of the attribute used as the selection criteria.

— ?=- Specifies the type of matching to be used. For a string, the only
option is a complete match or equal to. For numeric values, the
satisfying condition could be less than, greater than, or equal to the
specified value.

— VALUE - Value that the attribute must match for selection.
Multiple attributes can be used as matching criteria. Attributes can also
be deleted as needed.

3) Click the OK button; the software goes through all the objects in the
scenario looking for those that match the specified criteria. When it finds
objects that match the given criteria, it marks those objects as selected.
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Group
Selection/Action >
Action Filter

Save Object
Selection Set

Load Object
Selection Set

Edit > Group Selection/Action > Action Filter: Used in conjunction with the

object selection feature. A similar interface is provided for applying action on the
selected objects.

i—]Gruup Action ﬂ
Object Type:
[~ Organization [~ Relationzhip [~ Intemal Link [~ Radio Link
| Opfac [~ Mebwark [~ Eztemnal Link [ Planning Link.
[~ Device [~ IER [~ Sateliite Link
|
Attr Mame [2= [waLUE ]
Opfac Mame lJTFI

Delete |

0K Cancel

Figure 3-12 Group Action dialog box

1) Select the type of object to which you want to apply group action.

2) Select the attribute that needs to be changed. In the above example, the
user selected the Opfac Name attribute.

3) Specify the value. In the previous example, the user chose JTF as the
name to be set on all selected OPFACs.

4) Click OK; the software goes through all the selected organization objects in
the scenario and sets the trajectory attribute on them.

Edit > Save Object Selection Set...: Allows you to save an object selection set
to a .selset file in the SB_Data directory.

Edit > Load Object Selection Set...: Allows you to choose a saved object
selection set file from the SB_Data directory to load.

JCSS/Release 7.0
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Edit Objects Using

Template

Edit > Edit Objects Using Template...: Allows you to specify the content you
want to include in your report. When you generate a report (by clicking
Generate), your content settings are saved and will be reloaded the next time
you generate a report.

—#]Edit Objects Using Template x|

Select table to include in user report;

B | spplication |ﬂ

Frame Relay
Irmpart Infarmation
IP

LAM Switches

M ainframe

MPLS

O5PF

Server

TCP

[ Include only selected objects
[ lgnaore wiews

Generate I LCloze | Help |

Figure 3-13 Edit Objects Using Template dialog box

* Select tables to include in user report treeview: Specifies which tables of
which categories should be included in the report. To select an entire
category of tables, click on the top-level category entries. To select an
individual table, expand the top-level category subtree and click on the table
entry. Selected tables and categories show a green check mark. Categories
with some but not all of its tables selected display a green dot instead.

* Include only selected objects in report checkbox: Indicates that table data
will be collected only for objects that are currently selected in the network.

* Ignore views checkbox: Indicates that table data will be collected even for
objects that are not in the current view or views of the network.

¢ Generate button: Generates the table data for all of the selected tables.

* Close button: Closes the dialog box but retains any table selections.

TR-3-14
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Edit Attribute Edit > Edit Attribute Template...: Allows you to edit the objects in your attribute
Template templates.

—#]Edit Attribute Template

Categorn narme: I unnarmed

Template name: I unnamed

Irzlude: IN::u:Ies j Logical selection: | UMSET

Colurnn Title | Colurnn 4 alue ;I 1)

= Full Hierarchical Mame

Duplicate
Edi...
Delete

Mowve Up

kove Down

REEElEE LS

Add Drilldovn

4 o

Edit Objects... Ereview LCancel I ﬁave.ﬁ.s...l Help

Figure 3-14 Edit Attribute Template dialog box
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Project Defaults > Edit > Project Defaults > Link: Specify the default values for a link’s attributes
Link based on the link type.

ﬁLink Defaults O] x|
Drefaulks for Link Type: | PPP_Z23E. |
SLD Link Type Code:  [F
Clazzification: I Unclazsified LI
Fonward B andwidth: I 28.00 kbp=
Reverse Bandwidth: I 28.00 kbps
Frequency: I 0.00 kHz

Murnber of Yaice Channels: IEI

Channel Size for Yaice: I 16.00

Link bMOP Probe: I Dan't Include

Capacity [Fbpz] ;I Ingert
33
LTS lI

Delete

b,

Cancel

Figure 3-15 Link Defaults dialog box

1) Specify the desired default values for a particular link type.

2) If needed, change the default values for another type by choosing the
desired type from the Defaults for Link Type drop-down menu.

3) Click the OK button to save the default values.
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Project Defaults > Edit > Project Defaults > Network: Specify the default values for a broadcast
Network network’s attributes based on the network type.

—#{Network Defaults -0l x|
Defaulks far Metwark, Tope: Ieplrs_l:nrdn::st_? :l
Clazsification: I Unelazsified |
Bandwidth; [120.00 Kbps
Frequency: I 150.00 kHz
Utilization Probe: IIncIude j

Capacity [Fbpz] ;I Ingert |
15 Delete |

20
40
a0

Figure 3-16 Network Defaults dialog box

1) Specify the desired default values for a particular network type.

2) If needed, change the default values for another type by choosing the
desired type from the Defaults for Network Type drop-down menu.

3) Click the OK button to save the default values.
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Project Defaults > Edit > Project Defaults > IER: Specify the default values for an IER’s attributes
IER based on the IER’s traffic type.

e
VDICE Traffic| DATA Traffic [VTC Traffc]
Classificatian: I Unclazsified |
Priority: [ ROUTINE =l
Equipment: | COMPLTER |
Ao, Size: |'||:|24 secs/bytes
Perizhabiliby: I 500.000000 SECE
DistType: | CONSTANT |
Dizt. bean: ITED.DUDUUD zeCs
Start Time: ITEU.UUUUUU secs
Stop Time: IEND SBCE

m LCancel

Figure 3-17 IER Defaults dialog box

1) Specify the desired default values for a particular traffic type.

2) If needed, change the default values for another type by choosing the
desired type from the Defaults for Traffic Type drop-down menu.

3) Click the OK button to save the default values.

Project Defaults > Edit > Project Defaults > Requirements Matrix: Edit the default requirements
Requirements matrix questions that are applied to all new projects and scenarios created in
Matrix the Scenario Builder. All fields are editable and can be modified by clicking on
a cell and entering new values.
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The Applications column displays application names for the specified service.

If there is more than one application for the service, a comma separates

application names with no space after the comma separator.

:—i—]Default Requirements Matrix i ] 4
Choose Defaults File EMMETWARSSS cenanio_Builder\ 10 5.4 netwarshrules\F egh atriz. gdf
Vaice Requirements
Fow | Question Service Applications d
How mary tactical phone ugsers? Tactical
2 How many DSN users by precedence and access level? DSH
3 How many DRSN users? DRSH
4 |3 Commercial Access needed? How many lines/tunks?
5 |5 Host Nation Telephone Access needed? How many lines/trunks?
B How many cellular phones are needed? Cellular
7 How many pagers are needed? FPager
8 How many IMARSAT Mobile Satelite Services M55 )/rndium users? M55
Woice Services | D ata Services | WIC Services Message Services Jaint Digital Metwoark
Add Question | Delete Question | LCloze |

Figure 3-18 Requirements Matrix Default dialog box

Clicking on the buttons below the table displays different functional areas.
Questions can be added or deleted via the Add Question and Delete Question

buttons.

By default, the Save button saves the changes and replaces the ReqMatrix.gdf
file located in the Rules directory. To change the default file, click the Choose
Defaults File button. Selecting this button launches a file chooser dialog box.
Select the desired default file; the contents of the alternate file import into the

Defaults Requirements Matrix dialog box.

Choose Defaults File

Loak jh: I 3 Rules

21|
x| « @ ck EB-

Missiondnalysis,gdf
MissiondnalysisJOPES, gdf
precedence.gdf
Reqiatrix,gdf
ReqMatrixl.gdf

Kl

SB_File_Histary.odf
thread_dist.gdf
krafFic, gdf
TrafficThreshalds,.gdf

[

File narne: IMissiun&naI_l,lsis‘l .gdf

Open I

Files of type: IHequirement t atrix Questions Files [*.gdf) j Cancel |

Figure 3-19 Specifying the Requirements Matrix defaults file

JCSS/Release 7.0
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Project Defaults > Edit > Project Defaults > Mission Analysis: Edit the default mission analysis
Mission Analysis questions that are applied to all new projects created in the Scenario Builder.

iﬁ-]Missiun Analysis Questions - |EI|£|

Choose Detaults File C:AMetwarshS cenano_Bulderh1 2. 0.A\netwarsbrulesiMizsiondnalyzis. gdf

Mizzion Analysiz: Situation

Fh:u...l [luestion Anzwer/Comment ;l

1 YWhat iz the geographic operational area? M A,

2 What iz the location of the JTF Headquarters? M A,

3 Whoig the potential adversary? P A,

4 What are the threat's capabilities bo conduct infarm... WA —

] Daes a joint farce plan exist to counter this threat? WA

B ‘Wha are the subordinate compaonent and supparti... WA

7 Wha are the participating coaltion farces? M A,

g8 What are the command relationzhips? M, LI
Situation | Mizzion I Execution Adrin & Logistics | Cormmand & E-:untru:ull

Add Question | Delete Question I Cancel |

Figure 3-20 Mission Analysis defaults
Answer questions by clicking on a cell and entering values.

Clicking on the buttons below the table displays different functional areas.
Questions can be added or deleted via the Add Question and Delete Question
buttons.

Saving the changes will modify the MissionAnalysis.gdf file located in the
Rules directory. To change the default file, click the Choose Defaults File
button. Selecting this button launches a file chooser dialog box. Select the
desired default file; the contents of the alternate file import into the Mission
Analysis Defaults dialog box.
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Project Defaults >
Distance Between
OPFACs

Preferences >
Device Model
Map > New

Edit > Project Defaults > Distance Between OPFACs: Configure the
preferences for the Distance Between OPFACs feature. See field descriptions
below.

:—iﬁ:—]DistancE Between OPFALS EI

Digplay Duration |4 [zecondsz]

[+ Do naot hide "distance links"

Dizplay Unitz i~ Meters i~ Kilometers
" Feet * Miles

Elevation Threshold | 500 [meters)

ak. I Cancel |

Figure 3-21 Distance Between OPFACs Defaults

Display Duration — Specifies the amount of time that the OPFAC Distance
Links will display if you do not have the Do not hide “distance links”
preference enabled.

Do not hide “distance links” — Specifies whether the Scenario Builder will
automatically hide the OPFAC Distance Links after a specified amount of
time (refer to the Display Duration field above).

Display Units — Sets the units in which the OPFAC Distance Links will
display their distances.

Elevation Threshold — Determines whether the distance calculation will
consider the Earth’s curvature. If both OPFACSs’ altitudes fall below this
value, it will consider the Earth’s curvature, but it will not if either OPFACS’
altitude exceeds or equals this value.

Edit > Preferences > Device Model Map > New: Bridge the differences in
model names/naming conventions that exist between JCSS and Network
Engineer. Device model mapping allows you to define a mapping between two
sets of device model names. During export of data, the JCSS XML processing
code can substitute model names in the source data with alternate names in the
target data.

JCSS/Release 7.0
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1) From the Scenario Builder, select Edit > Preferences > Device Model
Map > New. The Choose Source and Target Model Name Lists displays.
Use this dialog box to select a source model list and a target model list; this
means that device model names in the source list will be replaced with
designated model names in the target list.

i—][huuse Source and Target Model Mame Lisk El
Source Model List; IE:'\N ehwarzhzer_Datahzource_list txt Browsze. .. |

Target Madel List: | C:A\Metwarshzer_Dataktarget_list bt Browsze. ..

ar. I LCancel |

Figure 3-22 Choose Source and Target Model Name Lists dialog box

2) Click the Browse button for the Source Model List. The Source Model List
Browser dialog box displays.

3) Open the appropriate Rules folder.

Source Model List Browser ﬂil
Laoak in: Ia Rules j A I.:._:.F Ef-

JMMS_inpuk_names, txk
IMMS_oukput_names, bxt

File name: I COpen

Filzz of type: IDevice todel Lists [*kat] j Cancel |

Figure 3-23 Source Model List Browser

Note—JCSS provides template source and target model list files from which you
can choose in the Scenario_Builder/12.0.A/netwars/rules directory. You can select
a template file, modify it, and save it under a new name in the User_Data/Rules
folder to use again. Remember: Save your rules files to the default
User_Data/Rules folder so you can easily find them again.

4) Select the desired input file and then click Open.

5) Click the Browse button for the Target Model List. Repeat steps 3-4, this
time selecting an output file as the target model list.
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6) Click OK. The Edit Device Model Mapping File dialog box displays.

iﬁ-]Edit Device Model Mapping File

Current File;  <Mew File>

=101 %]

Unmapped Source Model Mames

M apped Target and Source Model Mames

[ [FCCa00%7 |;| —{ ] AMN/FCC-100 V7 ;l

[ FCC100%9 1 AMAFCC-100 V19

[ F5C-72 H AMAFSC-TE

[ GRC-225 H AM/GRC-226

[ GRC-2339 H AM/GRC-239

[ G5C-29 H AMAGSC-39

[0 GsCch2 H] AMAGSCE2

[0 GenericH 320 Bridge H] ANARC-142

[0 KGA75ATH H] ANATRCA70 V]2

[0 KGA7RIP H] ANATRCA70 V)3

[ MRC-142 H ANATRCA70 V]G

[0 REDCOM IG= 1 Shelf 1 AMATSC-1004

[0 REDCOM IG= 2 Shelf H AMATSC152 [wETSSF)

[0 REDCOM IG= 3 Shelf H AMATSCA152 [w TSSF)

[0 REDCOM IG= 4 Shelf H AMATSCA152 [wo TSSP)

[ REDCOM IG# 5 Shelf H AMATSC154

[ REDCOM IGH B Shelf H AMATSCE5E

[ REDCOM IGH 7 Shelf H AMATSCE5C

[ REDCOM IG# 3 Shelf H AMATSCE5C (wETSSP)

M1 D eAiinimes Deidan i ARIITCT 020 o
ki pillsi o

tap s | << Unmap |
Save | Save bz, I Cloze |

Figure 3-24 Edit Device Model Mapping File dialog box

Devices in the Unmapped Source Model Names panel (from the source
model list) can be mapped to only one device in the Mapped Target and
Source Model Names panel (from our target model list). However, it is
possible to map more than one source name to the same target name

(many-to-one mapping).

Select the desired model in the Unmapped Source Model Names panel.
Next, in the Mapped Target and Source Model Names panel, select one

or more models.

JCSS/Release 7.0
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8) Click the Map>> button. The source device name displays under the target
device name in the Mapped Target and Source Model Names panel.

=]

i

— ] &M/TSC-152 [w ETS5P)
— ] &M/TSC-152 [w TSSF)
— 1 AM/TSC-152 [wo TS5P)
— ] AM/TSC-154

[ M/ T GL-05E
TSC-35B

— ] AM/TSC-85C
— ] &M/TSC-85C (wETS5F)
— | AM/TSC-33B
— ] AM/TSC-93C
— ] AMATSC-93C (w ETSSP)

— ] AMNATSC-944
— ] &MATSC-964 -
ﬂ'_l AL ITSm 40 _}I—I

Figure 3-25 Mapped

devices

9) Click the Save button. The Device Model Map Browser dialog displays.

Name the file in

Preferences >
Device Model Map
> Open

Map Browser dialog

Preferences >
Device Model Map
> Choose

i—]DE?icE Model Map Preferences

the File Name field and then click Save.

Edit > Preferences > Device Model Map > Open: Launches the Device Model

box which enables you to select a previously created

device model map to edit using the Edit Device Model Mapping File dialog box.

Edit > Preferences > Device Model Map > Choose: Use this dialog box to
select an import map (source model list) and an export map (target model list)
defaults for device model mapping.

Impart b ap: Il

E=port Map: I

|
Browsze. . |
_Bowse.. |

Browse. ..

(o] |

Cancel

Figure 3-26 Device Model Map Preferences dialog box

1) Click the Brows

e buttons for the Import Map and Export Map fields to

select desired device model maps.

2) Click OK.

TR-3-24
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Preferences >
Functional Profiles

Preferences >
Geographical
Coordinates

Edit > Preferences > Functional Profiles: Set default functional profiles and
functional names. Every OPFAC has one or more functional names. A
functional name maps an IER or series of IERs to a producer/consumer OPFAC
pair. A collection of such functional names is called a functional profile. A
functional profile can be defined locally on an individual OPFAC, or globally, so
that it is available to all OPFACs and across different scenarios.

i—]Functiunal Profile x|

Profile; ESampIe ll

Mew. | Bename... Remowve.. |

Functional Mame | Type 5|
A Cs E uplicit
|F202 E uplicit

Ihzert Delete
ak. I LCancel |

Figure 3-27 Functional Profile dialog box

1) Add, rename, or remove functional profiles as needed.
2) Insert, delete, or edit functional names as needed.

3) Click OK.

Edit > Preferences > Geographical Coordinates: Sets the default
geographical coordinate system view displayed in the workspace of the
Scenario Builder. There are three types of geographical coordinate systems
available in JCSS: Lat/Long, UTM, and MGRS.

| .iﬁ-]Eeugraphical C = -10| x|
Select Geagraphical Coardinates for Units:
{+ LatiLaong

£ UTh
i MGRS

Cancel |

Figure 3-28 Geographical Coordinates dialog box

1) Select the Lat/Long, UTM, or MGRS radio button.

2) Click OK.

JCSS/Release 7.0
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Preferences > Edit > Preferences > Owners List: Set owner information for units marked for

Owners List subordinate query. Modify existing records or add/delete records to the list as
needed.

JRI=TES
Lazt Mame | First Mame | Title | Organization ﬂ
Barari Pillp Major  [DISA |
Ortiz Tita b ajar (] =1
K1 _>I_I

Add | Delete ag | Cancel |

Preferences >
Security
Classifications

Figure 3-29 Owner List dialog box

Owner information contains four fields: Last Name, First Name, Title and
Organization. All fields, except the Title field, are required fields.

Edit > Preferences > Security Classifications: Set security classification for
a variety of items in a scenario, such as devices and IERs. This dialog allows
you to add, remove, or change values in the list of recognized security
classification values. The list is used to populate drop-down lists in edit fields
and table cells that specify security classification values. Since some fields and
cells only allow values from this list, you will need to modify this list in order to
specify custom security classifications. Any value is permitted, although
duplicates are not allowed in the list.

iﬁ-]ﬁecurity Classifications x|

|hclagzifie DEFAULT ;l

Clazzified

Confidential

Secret

Top Secret

K1 _>IJ
Up | Do Ingert | Delete | Set Default |

Save I

Cancel |

Figure 3-30 Security Classifications

The list order of an entry indicates the classification’s level of restriction. Less
restrictive classifications appear toward the top of the list.

TR-3-26
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Preferences >
Traffic Flow
Thresholds

A value in the list may be modified by selecting and editing it. The Up button
moves the selected value toward the top of the list. The Down button moves the
selected value toward the bottom of the list. The Insert button inserts a blank
entry above the selected value. The Delete button deletes the selected value.
The Set Default button sets the selected classification as your default. The
Save button saves all changes. Once saved, the changes will affect all edit
fields and table cells, but the values stored in those attributes will not be
modified.

Edit > Preferences > Traffic Flow Thresholds: Specify a minimum value and
the colors to be used for each threshold; traffic flow thresholds are used in
conjunction with the Aggregate Traffic Flows feature. Flows are colored based
on the threshold they fall under. If the load of an aggregate flow is more than the
highest threshold, the flow is colored black. If the load is lesser than the
minimum threshold, the flow is not displayed. The default minimum value is 0
Kbps.

<] Traffic Flow Thresholds =1
Traffic Load Colar

inirnm: 0.000

;

white -
Threshald 1: 2000
¥ ellaw

Lo

Threzhold 2 4.000

.

Green
Threszhald 3: 10.000
Blue
Threshald 4: 20.000

Fed

Lef Lo

Threzhald & 500.000

Help... |

Figure 3-31 Traffic Flow Thresholds dialog box

4999

Cancel

Set desired traffic load/color combinations and then click OK.

JCSS/Release 7.0

TR-3-27



3—Scenario Builder

JCSS Technical Reference Manual

Preferences >
Advanced

Edit > Preferences > Advanced: Display the Preferences Editor and set
environment attributes that control program operation. These values are stored
in a file called the environment database file (env_db for short).

iﬁ-]PrEferences Editor - CA\METWARS 2007 Scenario - |I:I|5|
Search for: || I.-’-'-.n_l,lwhere =]
Arrange by I Groups | [ Advanced view
| M arme |"v"alue ;I
= |
0NN
ACE eation
Automation Destroy Decorations at End TRUE
Dashboard Display OPNET averlay in 3D Visualizer  FALSE
Dezign Action S Earth G i Model oht sph
Discrete Event Sim mil SIS R R nght_zphe
Expart Entity b apping Libram ophet_3dr
Irport HLA Fed Fil= Marne <hull
Licenzing HL2 Federation Mame OPMET_:
Mizcellaneous Launch 30 Mebwork, Wigualizer FALSE
NETCOF Launch 30NY Communication FALSE
NetDactor Mapping Librany Initialization Argument <nullz
Product Perfarmats .
Project E ditor b amirmurn 30MY Meszages per Second 0O
Feparting RPR .FEIM Yerzion 1
Terain Modeling Terrain Database Uzed by 30 Metwork, ... <ol -
Traffic 4| | r
Troublezhooting .
Ll — Preference Information
Wirtual CLI M ame: Dielay for Entity Creation ;I
Walue: 1
Dezcrption: Murnber of zeconds to wait between the
_| [ _ILI creation of RTI objects and the -
4 3

ok LCancel Loy Help

Figure 3-32 Preferences Editor dialog box

Search for: Enables you to search for preferences. The system searches for
words or values containing the specified text in whole or in part (a wildcard
search is assumed.) From the pull-down menu, select the preference
information to include in the search: Anywhere specifies to search Tags,
Names, Values and Descriptions; In Names specifies to search Tags and
Names only; and In Values specifies to to search Values only.

Arrange by: Enables you to display preferences by category. From the
pull-down menu, select Groups to arrange preferences by group (filters the
list of displayed preferences to a specific group by selecting the group in the
treeview,) or Source to arrange preferences by source (preferences are
classified based on the source of their values.)

Advanced view checkbox: Toggles between showing an advanced or basic
view of the preferences table. In the basic view, the table shows the name

TR-3-28
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View Menu

Show Logical
Views

and value of each preference. In the advanced view, the table shows the
name, tag, source of the preference's value and the value itself.

OK button: Saves changes and closes the Preferences Editor.
Cancel button: Closes the Preferences Editor without saving changes.

Apply button: Saves changes.

View > Show Logical Views...: Specify filtering parameters for logical views.

+#]Logical ¥iew Selection x|
— Metwork Layer Filkers ———— — Securnity Claszification Filkers
" Technology Security Clazsification N
[P |
€ UHF Dékde
Service I Mew =

" Link 16
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[~ Consider Link Capacities

Help | Create YWiew I Save Settings Cloze

Figure 3-33 Logical View Selection dialog box

Network Layer Filters: Enables you to hide all devices except for those of a
particular layer of the network. (Note that this doesn’t necessarily mean OSI
network layer, but instead, it means the various devices that use a particular
protocol.) Network Layer Filters shown are only those which apply to the
deployed network.

Security Classification Filters: Enables you to filter elements of the
network based on their security classifications. Any custom classifications
added in the Operational view will be availabe here as well for filtering.

Duration and Start Time: These parameters are used to get the Capacity
Planner graphs that are used for filtering for various layers.
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Consider Link Capacities checkbox: This is another parameter used to get
the Capacity Planner graphs. A link capacity considered filter will result in the
Capacity Planner creating a graph that may not show complete physical
connectivity of the devices due to link load. A link capacity ignored filter will
result in a graph that shows complete physical connectivity of the devices
regardless of link load.

Create View button: Creates the type of view that you specified and loads it
into a Network Showcase window. The filter specifications are applied to the
logical view model.

Save Settings button: This button is availabe from the Operational View and
gives you the option to save the settings instead of creating a logical view
network with the specified settings at this time.

Close button: Closes the dialog without making any changes to the model.

View > Show Network Browser: Use the Network Browser, a pane that lists

obj
loc

:ﬁ]Scenariu Builder: UserGuide_CP_Scenario Scenario: UserGuide_C

ects (organizations, OPFACs, nodes, devices, links, etc.) in the network, to
ate objects in the workspace and edit their attributes.
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Figure 3-34 Network Browser

You can modify the object list by applying filters. Available filters include:

Classification: Filters based on the classification attribute on each device.

Equipment Type: Filters based on the equipment type attribute on each
device.
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Ownership: Shows the associated owner for each device in the scenario.

Used with Collaborative Planning.

Broadcast Networks: Shows all of the broadcast networks in the scenario
and to which OPFACs/devices they are attached.

Relationships: Shows all of the relationships in the scenario and to which

OPFACs they apply.

Satellite Links or Radio Links: Shows all of the satellite (or radio) links in
the scenario and to which OPFACs/devices they are attached.

Click on an object in the object list to display it in the workspace (upper-right.)
Select and check an object to display it in a Showcase window (lower-right.) Use
options provided on the right-click menu to modify object attributes.

File  Edit

Viewy  Scenarios
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